Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78911 - read timeout does not work for https URLs
Summary: read timeout does not work for https URLs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl-libwww-perl
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-03 13:06 UTC by Geoffrey D. Bennett
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-11 11:47:46 UTC


Attachments (Terms of Use)

Description Geoffrey D. Bennett 2002-12-03 13:06:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
The following command should timeout in one second:
/usr/bin/lwp-request -t 1 https://1.2.3.4/
(-t is documented as being the amount of time in seconds to wait for a response
from the server before returning a timeout error)

Version-Release number of selected component (if applicable):
perl-libwww-perl-5.65-2

How reproducible:
Always

Steps to Reproduce:
Run: /usr/bin/lwp-request -t 1 https://1.2.3.4/

Actual Results:  The request took over 3 minutes to timeout.  The error is '500
Connect failed: connect: Connection timed out Connection timed out'

Expected Results:  The request should have timed out after 1 second with an
error '500 read timeout'.

Additional info:

This problem is present in RHL 7.3 (perl-libwww-perl-5.63-9) as well as RHL 8.0
(perl-libwww-perl-5.65-2).

Comment 1 Marius Feraru 2004-11-26 14:18:59 UTC
upgrade to a newer version.

i cannot reproduce it on my test system:

altblue@nop:~$ time /usr/bin/lwp-request -t 1 https://1.2.3.4/
500 read timeout

real    0m1.278s
user    0m0.220s
sys     0m0.032s

altblue@nop:~$ time /usr/bin/lwp-request -t 5 https://1.2.3.4/
500 read timeout

real    0m5.256s
user    0m0.229s
sys     0m0.026s

altblue@nop:~$ rpm -q perl-libwww-perl
perl-libwww-perl-5.79-6



Note You need to log in before you can comment on or make changes to this bug.