Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78904 - bind crashes after a bunch of reloads under high load
Summary: bind crashes after a bunch of reloads under high load
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 7.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-03 10:07 UTC by Kirill Pushkin
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-16 21:01:54 UTC


Attachments (Terms of Use)

Description Kirill Pushkin 2002-12-03 10:07:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Configure name server with >= 800 zones
2. Reload it every 30 minutes with rndc reload (add or delete zones)
3. Wait 1-3 day(s)
	

Actual Results:  Dec  3 06:01:39 x-files named[6769]: adb.c:1746: fatal error:
Dec  3 06:01:39 x-files named[6769]:
RUNTIME_CHECK(((pthread_mutex_lock(((&adb->nameloc
s[bucket]))) == 0) ? 0 : 34) == 0) failed
Dec  3 06:01:39 x-files named[6769]: exiting (due to fatal error in library)

Expected Results:  It must work without crashes

Additional info:

bind-9.2.1-1.7x.2
RedHat Linux 7.2 with latest updates

Comment 1 Daniel Walsh 2003-01-07 16:34:20 UTC
Named seems to be having a problem in multi-threaded smp environments.  ISC
seems to be recommending that you download the latest named package and build it
with threading turned off.  You could attempt this an see if the problem goes
away.  Red Hat has not decided how we are going to approach these problems yet.

Dan

Comment 2 Daniel Walsh 2003-01-16 21:01:54 UTC
We believe this might be solved by the new threads library.  Please attempt this
with the latest Beta release of 8.1.

Dan


Note You need to log in before you can comment on or make changes to this bug.