Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78898 - RPM --prefix does not work as expected.
Summary: RPM --prefix does not work as expected.
Keywords:
Status: CLOSED DUPLICATE of bug 75057
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-03 05:27 UTC by Hema
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-03 05:27:33 UTC


Attachments (Terms of Use)

Description Hema 2002-12-03 05:27:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; YComp 5.0.0.0)

Description of problem:
I am using Redhat Linux 8.0 and I was trying to build my own package which 
consists of few shell scripts. I created a relocatable package which allows the 
user to specify the location where it needs to be installed. I was able to 
create the package. But during installation when I tried to install using --
prefix option, the package did not install in the location specified by me, but 
it installed in the default directory specified while building. Please provide 
the fix for the same at the earliest.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a relocatable package by specifying "Prefix:" in the spec file.
2.Create the package .rpm
3.Use --prefix when you install.


Actual Results:  When I tried the above steps, it installed in the default 
location as specified in the package.

Expected Results:  Actually, since it is a relocatable package, it should have 
installed in the location specified by me at the time of installation ( --
prefix)

Additional info:

Comment 1 Jeff Johnson 2002-12-03 18:49:49 UTC

*** This bug has been marked as a duplicate of 75057 ***


Note You need to log in before you can comment on or make changes to this bug.