Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78892 - postinstall script fails on info file installation
Summary: postinstall script fails on info file installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libgcj
Version: 1.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 23:49 UTC by Gary Peck
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-19 18:12:28 UTC


Attachments (Terms of Use)

Description Gary Peck 2002-12-02 23:49:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
The postinstall script of libgcj fails when upgrading because of an error in the
/usr/share/info/fastjar.info file. fastjar.info does not take ownership of the
'grepjar' and 'jar' info entries. As a result, when an old version of libgcj is
uninstalled, it does not remove the old 'grepjar' and 'jar' info entries.

Version-Release number of selected component (if applicable):
libgcj-3.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. Have a version of libgcj already installed.
2. Upgrade to a newer version of libgcj.


Actual Results:  rpm returns the following error:
install-info: menu item `grepjar' already exists, for file `(none)'
error: %post(libgcj-3.2.1-1) scriptlet failed, exit status 1


Expected Results:  The 'grepjar' and 'jar' info entries should have been
properly deleted by the old package's uninstall.

Additional info:

Here's a patch to /usr/share/info/fastjar.info that will fix the problem (I hope
it's short enough to warrant putting inline in the bug report):
--- fastjar.info.orig   2002-12-02 15:40:36.000000000 -0800
+++ fastjar.info        2002-12-02 15:40:36.000000000 -0800
@@ -8,9 +8,9 @@
 
 INFO-DIR-SECTION Individual utilities
 START-INFO-DIR-ENTRY
-* jar: Invoking jar.
+* jar: (fastjar)Invoking jar.
                             An archive tool for Java archives
-* grepjar: Invoking grepjar.
+* grepjar: (fastjar)Invoking grepjar.
                             Search files in a jar file for a pattern
 END-INFO-DIR-ENTRY

Comment 1 Jakub Jelinek 2002-12-04 15:52:22 UTC
Thanks, fixed on gcc CVS trunk and gcc-3_2-rhl8-branch, will appear in gcc-3.2.1-2.


Note You need to log in before you can comment on or make changes to this bug.