Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78874 - Floppy device not recognized on Asus P4T-E when usig grub
Summary: Floppy device not recognized on Asus P4T-E when usig grub
Keywords:
Status: CLOSED DUPLICATE of bug 75778
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 17:07 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:15 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-02 17:07:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Description of problem:
"floppy0: not floppy controllers found" (/var/logs/dmesg)
Floppy disk is not recognized, even if the proper lines in fstab have been entered 
"/dev/fd0 is not a proper block device"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Allways when booting into Linux, Windows 2000 has no problem with the floppy disk

	

Expected Results:  Disk should be accessible, as other systems dont have this
problem. It is Asus P4T-E specific 

Additional info:

Comment 1 Jeremy Katz 2002-12-02 17:13:45 UTC
This sounds like a kernel problem, not a problem with the boot loader

Comment 2 Need Real Name 2002-12-03 20:24:26 UTC
Tried to fix this problem with the following lines in grub.conf :
"kernel /boot/vmlinuz-2.4.18-18.8.0 disableapic ro root=LABEL=/"
or :
"kernel /boot/vmlinuz-2.4.18-18.8.0 noapic ro root=LABEL=/"
or :
"kernel /boot/vmlinuz-2.4.18-18.8.0 ro root=LABEL=/ disableapic"
or :
"kernel /boot/vmlinuz-2.4.18-18.8.0 ro root=LABEL=/ noapic"
The result is as before, as can be read in /var/log/dmesg :
"floppy0: no floppy controllers found"




Comment 3 Alan Cox 2002-12-16 05:01:32 UTC
The Asus P4T-E floppy is known to be very very weird and isnt supported by Linux.


Comment 4 Need Real Name 2002-12-16 10:42:15 UTC
Somebody advised me to install lilo as alternative bootloader instead as this
would be a grub-problem, a rather bleak option in my view. 

Still : The same motherboard does not have these problems with the floppy device
when dual-booting into Windows 2000 Professional.

Comment 5 Peter Ward 2003-02-14 08:44:07 UTC
I have the identical problem...RH 8.0, P4T-E MB, floppy controller is not
recognised. There are 2 other bugs open for the same issue, 75687 and 78874.
Please note that during installation the floppy WAS detected. I created a boot
disk. 

Comment 6 max 2003-03-05 10:55:47 UTC
Problem known with (almost all) P4-TE Asus motherboards not recognizing floppy
at boot; the bug does not depend on Rh 8.0, and is reproducible with different
linux distributions too. The floppy is OK once recognized.

I think the bug is reported with several different numbers, i lost count.

Proposed workaround: compile floppy as a module. It delays floppy recognition
and then system works reliably. Tested on RH 7.2, I am recompiling 8.0 to test
it again.


Comment 7 Alan Cox 2003-06-08 02:03:30 UTC

*** This bug has been marked as a duplicate of 75778 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:50:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.