Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78864 - smb:// handles authentication badly.
Summary: smb:// handles authentication badly.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
: 88114 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 14:36 UTC by Nils Olav Selåsdal
Modified: 2015-01-08 00:02 UTC (History)
5 users (show)

Fixed In Version: 2.6.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-22 18:38:08 UTC


Attachments (Terms of Use)

Description Nils Olav Selåsdal 2002-12-02 14:36:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
We have a small windows network, I've changed the /etc/nsswitch.conf
to include wins in the hosts: section, other than that, a default RH 8.0

If I type smb://hostname in the URL bar, it will display the shares on 
that computer, entering a share pops up a authentication dialog. Entering a
valid username/password doesn't help, the dialog just keeps popping up.
However if I enter smb://ausername:thepassword@hostname, it still pops up the
autentication dialog, but now entering the ausername and thepassword here also,
it works. I can brovse the shared folder/subfolders, copy files etc.

To bad with such an annoying(minor I guess) bug, Nautilus is about the only
valid alternative for normal users to reach windows shares.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start nautilus. enter smb://ahost for browsing a host, enter a share
2. If any authentication is needed, the auth dialog pops up.
3. Enter a valid usernam/password


Actual Results:  The auth dialog just reappears

Expected Results:  Succesfully authenticated for the rest of the session

Additional info:

If it means anything, we have a NT 4.0 PDC, and the workstations I'm trying to
access are win2k/XP machines.

Comment 1 Havoc Pennington 2002-12-02 14:53:55 UTC
I think it'd be good to target fixing this for next release.

Comment 2 Alexander Larsson 2002-12-03 09:56:08 UTC
Yes. There are various open smb authentication bugs that need to be fixed. I
plan to have a gnome-vfs-extras merge-and-fixathon soon.


Comment 3 Alexander Larsson 2003-02-17 10:43:54 UTC
Does gnome-vfs2-extras 0.99.10 fix this? I think this is a dup of bug 82992
which i believe is fixed.


Comment 4 Leonard den Ottolander 2004-03-09 15:59:25 UTC
*** Bug 88114 has been marked as a duplicate of this bug. ***

Comment 5 Leonard den Ottolander 2004-03-09 16:03:16 UTC
This is still an issue with FC 1, gnome-vfs2-extras-0.99.10-3.1.

Changing component to gnome-vfs2-extras and assigning.


Comment 6 Alexander Larsson 2004-03-10 08:49:59 UTC
It should work with the smb: support in gnome-vfs 2.5.x though, in
rawhide.

Comment 7 John Thacker 2006-04-22 18:38:08 UTC
Pretty sure this has been fixed for a long time, as the previous comment says. 
Works for me, anyway. Closing.


Note You need to log in before you can comment on or make changes to this bug.