Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78858 - redhat-config-xfree86 doesn't start when existing config is wrong
Summary: redhat-config-xfree86 doesn't start when existing config is wrong
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 09:37 UTC by Lene Jensen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-06 05:28:46 UTC


Attachments (Terms of Use)

Description Lene Jensen 2002-12-02 09:37:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-5 i686)

Description of problem:
After a kickstart which had "start X on boot" but no configuration for the
graphical component, the computers try to start X and then fails. After logging
in, I tried to run redhat-config-xfree86, and it refused to start, giving an
error about not finding the correct module. After copying a known good
XF86Config, I could start redhat-config-xfree86.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.kickstart machine with startxonboot, but do not configure the graphics
2.boot (and fail to get into runlevel 5)
3.log in and run redhat-config-xfree86
	

Actual Results:  Program refused to start, and gave error message (which I
forgot to write down); something about device not loaded

Expected Results:  the config tool should have started

Additional info:

Comment 1 Alexander Larsson 2002-12-02 10:09:54 UTC
It tries to first use the existing config file, but then tries to do a new one
from scratch. I have to have more information to figure out why it failed in
your case. Could you retry and save the full output and the X logs?


Comment 2 Brent Fox 2002-12-20 09:22:43 UTC
Any more info here?  We're kind of stuck without more data about the error
message that you saw when redhat-config-xfree86 failed to start.

Comment 3 Brent Fox 2003-01-06 05:28:46 UTC
Closing due to lack of information.


Note You need to log in before you can comment on or make changes to this bug.