Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78857 - gnome-panel crashes during XWindow+GNOME startup
Summary: gnome-panel crashes during XWindow+GNOME startup
Keywords:
Status: CLOSED DUPLICATE of bug 75138
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL: http://prawo.uni.wroc.pl/~konrad/rhl-...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 08:03 UTC by Konrad Zak
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-05 23:28:57 UTC


Attachments (Terms of Use)

Description Konrad Zak 2002-12-02 08:03:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.1) Gecko/20020826

Description of problem:
gnome-panel application crashes with "fatal error" message during XWindow+GNOME
startup after some customization of settings done 

Version-Release number of selected component (if applicable):
gnome-panel-2.0.6-9

How reproducible:
Sometimes

Steps to Reproduce:
Problem happens every time I start XWindow with GNOME, but supposly there is no
easy way to reproduce this problem in another system. That's why I choose
"Sometimes" option. It started to happen after I little bit customized
gnome-panel settings - content, behavior and screen placement. Moreover, it
happened for the first time after restarting XWindow, not during gnome-panel
configuration.

Shortly speaking, what I did is:

1. Customized gnome-panel settings. 
2. Closed XWindow session and started it again.

Then found the problem.

	

Actual Results:  I get message window, that you'll find in URL included.


Expected Results:  gnome-panel running properly

Additional info:

Some investigation on X server logs gave me following error message, that can be
useful:

system-tray-applet-ERROR **: file obox.c: line 107 (get_class): should not be
reached
aborting...

Comment 1 Nick Mumbach 2002-12-05 23:28:50 UTC
I believe I can confirm this bug ... I changed my Gnome Panel location from the
bottom to the right side of the desktop ... session continued to function
normally until the next time I logged in, at which point I received an error
window - 'Application "gnome-panel" (process 1001) has crashed due to a fatal
error. (Aborted)' from which I had no path to clean recovery ... I had to power
down and log in as a different user to do anything.  Repeatable on two separate
RH 8.0 systems. - email nmumbach@yahoo.com or nmumbach@keynotesystems.com

Comment 2 Havoc Pennington 2002-12-06 00:29:19 UTC

*** This bug has been marked as a duplicate of 75138 ***


Note You need to log in before you can comment on or make changes to this bug.