Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78856 - php4.2.3 compile crash
Summary: php4.2.3 compile crash
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.2
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 06:36 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-02 07:52:41 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-02 06:36:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; T312461)

Description of problem:
php4.2.3 had seg fault during compliation
see below for complier command

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Last entry on terminal when compliation stopped.

gcc -I. -I/usr/local/src/php-4.2.3/ext/standard -I/usr/local/src/php-4.2.3/main
-I/usr/local/src/php-4.2.3 -I/usr/local/src/apache_1.3.27/src/include -I/usr/loc
al/src/apache_1.3.27/src/os/unix -I/usr/local/src/php-4.2.3/Zend -I/usr/local/sr
c/php-4.2.3/ext/mysql/libmysql -I/usr/local/src/php-4.2.3/ext/xml/expat  -I/usr/
local/src/php-4.2.3/TSRM -g -O2  -c math.c && touch math.lo
math.c: In function `zif_fmod':
math.c:1065: Internal error: Segmentation fault.
Please submit a full bug report.

Entered 'make' command again and problem did not repeat.

Comment 1 Jakub Jelinek 2002-12-04 16:06:37 UTC
If the problem is not reproduceable, then it is likely a hardware problem.
Run memtest86 and other diagnostics.


Note You need to log in before you can comment on or make changes to this bug.