Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78844 - top crashes with Floating point exception
Summary: top crashes with Floating point exception
Keywords:
Status: CLOSED DUPLICATE of bug 67200
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-02 00:28 UTC by John Newbigin
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-02 00:28:12 UTC


Attachments (Terms of Use)

Description John Newbigin 2002-12-02 00:28:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
top prints out the first few summary lines and then zero, one or two cpu status
lines and then prints Floating point exception and exits.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
It is happening every time on the box in question now, but it used to work.

When I run with strace, it does not crash.

Actual Results:  Run1:
 11:21am  up 286 days, 17:50,  4 users,  load average: 0.03, 0.19, 0.56
203 processes: 200 sleeping, 1 running, 1 zombie, 1 stopped
Floating point exception

Run2:
 11:21am  up 286 days, 17:50,  4 users,  load average: 0.08, 0.19, 0.55
203 processes: 200 sleeping, 1 running, 1 zombie, 1 stopped
CPU0 states: 15.0% user, 84.0% system,  0.0% nice,  0.0% idle
Floating point exception

etc.

Expected Results:  Normal top output

Additional info:

When I run top with strace, it works but the system CPU usage looks wrong.

 11:24am  up 286 days, 17:53,  4 users,  load average: 0.08, 0.15, 0.47
204 processes: 201 sleeping, 1 running, 1 zombie, 1 stopped
CPU0 states: 16.0% user, 83.0% system,  0.0% nice,  0.0% idle
CPU1 states: 16.0% user, 83.0% system,  0.0% nice,  0.0% idle
CPU2 states: 50.0% user, 50.0% system,  0.0% nice,  0.0% idle
CPU3 states: 12.0% user, 87.0% system,  0.0% nice,  0.0% idle
Mem:  2574644K av, 2562656K used,   11988K free, 1329716K shrd,  122316K buff
Swap: 2097112K av, 1065336K used, 1031776K free                  470396K cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
31648 jnewbigi  10   0   572  572   456 S    24.0  0.0   0:01 strace
31649 jnewbigi  11   0  1124 1120   828 R    24.0  0.0   0:00 top
    1 root       8   0   376  336   316 S     0.0  0.0   1:31 init
    2 root       9   0     0    0     0 SW    0.0  0.0   0:00 keventd
    3 root      19  19     0    0     0 SWN   0.0  0.0   0:36 ksoftirqd_CPU0
    4 root      19  19     0    0     0 SWN   0.0  0.0   0:37 ksoftirqd_CPU1
    5 root      19  19     0    0     0 SWN   0.0  0.0   0:36 ksoftirqd_CPU2
    6 root      19  19     0    0     0 SWN   0.0  0.0   0:36 ksoftirqd_CPU3
    7 root       9   0     0    0     0 SW    0.0  0.0 209:01 kswapd
    8 root       9   0     0    0     0 SW    0.0  0.0   0:01 kreclaimd
    9 root       9   0     0    0     0 SW    0.0  0.0   0:00 bdflush
   10 root       9   0     0    0     0 SW    0.0  0.0   5:13 kupdated
   11 root      -1 -20     0    0     0 SW<   0.0  0.0   0:00 mdrecoveryd
   20 root       9   0     0    0     0 SW    0.0  0.0   9:47 kjournald

Comment 1 Alexander Larsson 2002-12-02 10:07:15 UTC

*** This bug has been marked as a duplicate of 67200 ***


Note You need to log in before you can comment on or make changes to this bug.