Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78824 - AisleRiot aborts on double mouse-click
Summary: AisleRiot aborts on double mouse-click
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-games
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-01 17:09 UTC by Need Real Name
Modified: 2015-01-08 00:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-24 03:21:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-01 17:09:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
AisleRiot occasionally aborts when a button-1 double click is used to move a
card to the home row in the default Solitare card game.  This happens maybe once
every twenty or thirty times that a double click is used to move a card home.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run /usr/bin/sol in its default configuration.
2. Play a game, using a double-click to move a card home whenever the
opportunity presents itself.
3. The problem occurs frequently enough that if I consistantly double-click
cards home, it's unusual to reach the end of a game prior to the game aborting.
	

Actual Results:  The game aborts.  If run from the command line, the following
two lines of diagnostics are printed as the game aborts:

    ERROR: In procedure car:
    ERROR: Wrong type argument in position 1: ()

Expected Results:  The game should continue to operate normally.

Additional info:

This is a pretty standard RHL 8.0 installation, using a 3dfx video card and a
Logitech wireless USB wheel mouse.

Comment 1 Ed Marshall 2003-03-22 19:39:34 UTC
There's a GNOME bug ID for this one now, since I just ran into a variant of this:

http://bugzilla.gnome.org/show_bug.cgi?id=108734

Comment 2 Christopher Aillon 2004-08-24 03:21:33 UTC
Fixed upstream


Note You need to log in before you can comment on or make changes to this bug.