Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78793 - Conflicts + Provides => impossible to install a package?
Summary: Conflicts + Provides => impossible to install a package?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://rpm.nogin.org/MetaPRL/rh80/htm...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-30 05:30 UTC by Aleksey Nogin
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-02 04:35:36 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 2002-11-30 05:30:39 UTC
rpm seems to be unwilling to install a package, thinking it conflicts itself!
This used to work in earlier versions of Red Hat.

# rpm -Uvh htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
error: Failed dependencies:
        htmldoc conflicts with htmldoc-nogui-1.8.23-1.rh8.0
# rpm -q htmldoc
package htmldoc is not installed
# rpm -q --whatprovides htmldoc
no package provides htmldoc
# rpm -q --provides -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
htmldoc
htmldoc-nogui = 1.8.23-1.rh8.0
# rpm -q --conflicts -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
htmldoc
# rpm -q rpm
rpm-4.1-1.06

The package I am trying to install can be d/l'ed at
http://rpm.nogin.org/MetaPRL/rh80/htmldoc-nogui-1.8.23-1.rh8.0.i386.html

P.S. rpm --rebuilddb does not help.

Comment 1 Jeff Johnson 2002-11-30 17:52:00 UTC
Your conflicts is mis-written, expressing
	Conflict with all versions of htmldoc.

Comment 2 Aleksey Nogin 2002-12-02 04:35:29 UTC
Exactly, htmldoc-nogui conflicts with any version of htmldoc. But htmldoc-nogui
is *not* htmldoc, it just provides it. 

Again, this used to work before.

Comment 3 Jeff Johnson 2002-12-02 14:59:23 UTC
Again, you have a Provides: in htmldoc-nogui

# rpm -q --provides -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
 htmldoc
...

that is triggering the conflict. Don't do that.

Comment 4 Aleksey Nogin 2002-12-02 15:54:27 UTC
OK, how then do I create a package htmldoc-nogui that has the following properties:

1) Any package that requires htmldoc, should install happily when htmldoc-nogui
is installed.
2) htmldoc-nogui conflicts htmldoc.

Note: this used to be possible with previous versions of RPM!

I could remove the Conflicts from the spec and rely on file conflicts, but that
just does not seem right...


Note You need to log in before you can comment on or make changes to this bug.