Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78776 - Keyboard interpretation problem
Summary: Keyboard interpretation problem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: termcap
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 17:24 UTC by Need Real Name
Modified: 2015-01-08 00:02 UTC (History)
2 users (show)

Fixed In Version: FEDORA CORE 4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-01 09:42:22 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-29 17:24:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Hi ! On several machines where RedHat 8.0 is recently installed, when I type 
the key "Alt Gr" I obtain the character 0 (zero).


This fault occurs i.e. with these keyboards profiles : fr-latin1 an us.


The same distribution installed on my portable (Packard Bell) has no problem.


RedHat 7.3 installed in the same material had no problem.


Thanks for help !


Regards, Francois



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot
2.login
3.type Alt-Grey touch (with numlock active)
	

Actual Results:  I obtain 0 on screen

Expected Results:  Nothing

Additional info:

Default appears when numlock is active

Table used : fr-latin1 an also us

Comment 1 Olivier Caudron 2003-01-27 10:25:31 UTC
FYI see bug #76897 that reports an identical problem.

Comment 2 Petr Raszyk 2005-09-01 09:41:07 UTC
This is not a bug in termcap (see bug #76897).
The console (a replacement for a real console) does not read termcap/terminfo
database.
Only an application running in the console/terminal/terminal-emulator can (but 
does not need) to read termcap/terminfo. For instance midnight-commander running
in the console reads (via ncurses-library or slang-library) termcap/terminfo
database.

Your issue could not be reproduced in FEDORA CORE 4  (using font 'default8x16').


Petr Raszyk




Note You need to log in before you can comment on or make changes to this bug.