Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78764 - emacs is broken
Summary: emacs is broken
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 13:16 UTC by Tim Waugh
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-02 03:45:28 UTC


Attachments (Terms of Use)

Description Tim Waugh 2002-11-29 13:16:22 UTC
Description of Problem:
Emacs doesn't work any more.  21.2-22 worked fine.

Version-Release number of selected component (if applicable):
21.2-23

How Reproducible:
100%

Steps to Reproduce:
1. Start 'emacs textfile' for an existing textfile

Actual Results:
Errors.

Expected Results:
textfile loads ready to edit

Additional Information:

Comment 1 Jens Petersen 2002-11-30 07:00:02 UTC
Works fine me for me.  What are the errors you're seeing?

Comment 2 Tim Waugh 2002-11-30 10:15:09 UTC
Firstly a seemingly harmless warning:

Warning: Lisp directory `/usr/share/emacs/21.2/leim' does not exist.

But then this in the minibuffer:

Symbol's function definition is void: defalias-maybe

Comment 3 Jens Petersen 2002-12-02 03:45:21 UTC
Thanks for pointing this out.  There were some functions only defined
in the apel package that were causing this in rpm-spec-mode-init.el.

This and the leim dir warning should be fixed in emacs-21.2-24.

Comment 4 Tim Waugh 2002-12-02 12:37:43 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.