Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78762 - xinetd and pop3d issues after update
Summary: xinetd and pop3d issues after update
Keywords:
Status: CLOSED DUPLICATE of bug 76146
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 09:08 UTC by Jean-Christophe Diomard-Arrazau
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-03 20:43:09 UTC


Attachments (Terms of Use)

Description Jean-Christophe Diomard-Arrazau 2002-11-29 09:08:10 UTC
Description of Problem:


 here is the messages i have in var/log when problems with ipop3 start to occur,
the only solution for them is to restart xinetd every 5 minutes , or to go back
to the previous version of xinetd,
here is the interesting part :

[snip]

Nov  6 13:49:52 jade ipop3d[2082]: Login failure user=arellano host=[10.8.2.185]
Nov  6 13:49:55 jade ipop3d[2082]: Logout user=arellano host=[10.8.2.185]
Nov  6 13:52:05 jade sshd(pam_unix)[27843]: session closed for user verdu
nov  6 13:52:05 jade su(pam_unix)[27889]: session closed for user root
Nov  6 13:53:22 jade xinetd[2169]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:53:22 jade xinetd[2169]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:53:23 jade xinetd[2171]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:53:23 jade xinetd[2171]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:56:22 jade imap(pam_unix)[2219]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost=  user=bouillet
Nov  6 13:56:22 jade xinetd[2227]: (2227) getsockname: Bad file descriptor
(errno = 9)
Nov  6 13:56:22 jade xinetd[2227]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:56:22 jade xinetd[2227]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:56:22 jade xinetd[2212]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:56:22 jade xinetd[2212]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:56:23 jade xinetd[2217]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:56:23 jade xinetd[2217]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:56:23 jade xinetd[2225]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 13:56:23 jade xinetd[2225]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 13:56:25 jade imapd[2219]: Login failure user=bouillet
host=louxor.univ-montp3.fr [193.52.136.237]
Nov  6 13:56:28 jade imapd[2219]: Command stream end of file, while reading line
user=bouillet host=louxor.univ-montp3.fr [193.52.136.237]
Nov  6 13:56:47 jade pop(pam_unix)[2277]: authentication failure; logname= uid=0
euid=0 tty= ruser= rhost=  user=vrg
Nov  6 13:56:49 jade ipop3d[2277]: Login failure user=vrg host=[10.50.0.23]
Nov  6 13:56:50 jade pop(pam_unix)[2281]: authentication failure; logname= uid=0
euid=0 tty= ruser= rhost=  user=arellano
Nov  6 13:56:52 jade ipop3d[2281]: Login failure user=arellano host=[10.8.2.185]
Nov  6 13:56:54 jade ipop3d[2277]: Logout user=vrg host=[10.50.0.23]
Nov  6 13:56:55 jade ipop3d[2281]: Logout user=arellano host=[10.8.2.185]
Nov  6 13:57:01 jade pop(pam_unix)[2298]: authentication failure; logname= uid=0
euid=0 tty= ruser= rhost=  user=khellil
Nov  6 13:57:03 jade ipop3d[2298]: Login failure user=khellil host=[10.8.2.74]
Nov  6 13:57:06 jade ipop3d[2298]: Connection reset by peer while reading line
user=khellil host=[10.8.2.74]
Nov  6 14:01:43 jade xinetd[2472]: (2472) getsockname: Bad file descriptor
(errno = 9)
Nov  6 14:01:43 jade xinetd[2472]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:01:43 jade xinetd[2472]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:01:46 jade xinetd[2471]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:01:46 jade xinetd[2471]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:05:56 jade imap(pam_unix)[2672]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost=  user=pellerin
Nov  6 14:05:58 jade imapd[2672]: Login failure user=pellerin
host=mel.univ-montp3.fr [193.52.136.237]
Nov  6 14:06:01 jade imapd[2672]: Command stream end of file, while reading line
user=pellerin host=mel.univ-montp3.fr [193.52.136.237]
Nov  6 14:06:30 jade xinetd[2701]: (2701) getsockname: Bad file descriptor
(errno = 9)
Nov  6 14:06:30 jade xinetd[2701]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:06:30 jade xinetd[2701]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2765]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:08:24 jade xinetd[2765]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2771]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:08:24 jade xinetd[2771]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2773]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:08:24 jade xinetd[2773]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2776]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:08:24 jade xinetd[2776]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2780]: (2780) getsockname: Bad file descriptor
(errno = 9)
Nov  6 14:08:24 jade xinetd[2780]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:08:24 jade xinetd[2780]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:11:24 jade imap(pam_unix)[2944]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost=  user=domergue
Nov  6 14:11:24 jade imap(pam_unix)[2946]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost=  user=domergue
Nov  6 14:11:27 jade imapd[2944]: Login failure user=domergue
host=mel.univ-montp3.fr [193.52.136.237]
Nov  6 14:11:27 jade imapd[2946]: Login failure user=domergue
host=louxor.univ-montp3.fr [193.52.136.237]
Nov  6 14:11:30 jade imapd[2944]: Command stream end of file, while reading line
user=domergue host=mel.univ-montp3.fr [193.52.136.237]
Nov  6 14:11:30 jade imapd[2946]: Command stream end of file, while reading line
user=domergue host=louxor.univ-montp3.fr [193.52.136.237]
Nov  6 14:12:46 jade imap(pam_unix)[2958]: authentication failure; logname=
uid=0 euid=0 tty= ruser= rhost=  user=domergue
Nov  6 14:12:48 jade imapd[2958]: Login failure user=domergue
host=mel.univ-montp3.fr [193.52.136.237]
Nov  6 14:13:44 jade xinetd[3051]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:13:44 jade xinetd[3051]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:14:48 jade xinetd[3110]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:14:48 jade xinetd[3110]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:15:46 jade xinetd[3151]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:15:46 jade xinetd[3151]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:15:46 jade xinetd[3152]: fcntl( 7, clear close-on-exec ) failed: Bad
file descriptor (errno = 9)
Nov  6 14:15:46 jade xinetd[3152]: dup2( 7, 0 ) failed: Bad file descriptor
(errno = 9)
Nov  6 14:15:51 jade imapd[2958]: Autologout user=domergue
host=mel.univ-montp3.fr [193.52.136.237]
[snip]


i can send you the complete sysreport if you want.

the only solution they could find was, to go back to the previous version.



Version-Release number of selected component (if applicable):xinetd-2.3.9-0.71


How Reproducible: everytime you update the cd package


Steps to Reproduce:
1. up2date
then wait ..
2. 
3. 

Actual Results:


Expected Results:

a non saturation of the pop3d deamon
Additional Information:
	
The onl soolution we could have was ro uninstall this package and go back to the
xinetd package from the installation CD

Comment 1 Stephen Samuel 2002-12-03 20:43:01 UTC
This is actually a duplicate of bug #78104 / bug #76146. There is an errata
update to xinetd follow 76146 for the errata
(yes, it results in a backrev to xinetd-2.3.7-5.i386.rpm)


Comment 2 Bill Nottingham 2002-12-03 20:51:53 UTC

*** This bug has been marked as a duplicate of 76146 ***


Note You need to log in before you can comment on or make changes to this bug.