Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78761 - Installer of phpAdsNew doesn't work
Summary: Installer of phpAdsNew doesn't work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://sourceforge.net/forum/forum.ph...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 08:36 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-29 10:05:16 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-29 08:36:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2) Gecko/20021127

Description of problem:
On http://localhost/admin/install.php:
----------------------------------------------------------------------
Fatal error: Cannot redeclare phpads_isconfigwritable() (previously declared in
/var/www/html/admin/lib-config.inc.php:30) in
/var/www/html/admin/lib-config.inc.php on line 28
----------------------------------------------------------------------

Explanation from phpAdsNew forum:
----------------------------------------------------------------------
Someone told me that there might be problems with php-support with the Apache
version 2.0 that comes with Redhat 8.

He said that the php-support is "experimental".

Maybe You should downgrade Your Apache-version to 1.3.27.
----------------------------------------------------------------------

Any help will be appreciate.
Keep the good work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start httpd and mysqld services
2.untar phpAdsNew release or cvs under /var/www/html
3.start a browser pointing on http://localhost/
	

Actual Results:  Fatal error: Cannot redeclare phpads_isconfigwritable()
(previously declared in /var/www/html/admin/lib-config.inc.php:30) in
/var/www/html/admin/lib-config.inc.php on line 28

Expected Results:  I should have the installer of phpAdsNew.

Additional info:

I can't "downgrade" to Apache 1.3.x, my server is in production now.
How can I do?
I hope there will be an errata for php because it appears there is a lot  of
problem with the interaction with Apache 2.0.x

Comment 1 Joe Orton 2002-11-29 09:50:57 UTC
In /etc/php.ini, change the setting:

  short_open_tag = Off

to

  short_open_tag = On



Comment 2 Need Real Name 2002-11-29 10:03:34 UTC
I'm sorry but I changed this directive as you said in php.ini, restarted apache,
verified with phpinfo that short_open_tag is On, but the problem still remains
as you can see:


Fatal error: Cannot redeclare phpads_isconfigwritable() (previously declared in
/var/www/html/admin/lib-config.inc.php:30) in
/var/www/html/admin/lib-config.inc.php on line 28

Comment 3 Joe Orton 2002-11-29 10:05:09 UTC
Then it WORKSFORME, at least.

I downloaded phpAdsNew-dev16092002.zip on a clean 8.0 install, set
short_open_tag = On, and I can load the installer page.  Maybe you can try a
different version of phpAdsNew?

Comment 4 Need Real Name 2002-11-29 10:10:55 UTC
My firsts tests were done with both cvs edition and official release but for
this last test (short_open_tag), I have only tested with cvs edition.

It works perfectly now with the official release, I thank you very much for your
so quick answer.

Keep the good work


Note You need to log in before you can comment on or make changes to this bug.