Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78758 - VMware crashes when suspending virtual machine
Summary: VMware crashes when suspending virtual machine
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 07:21 UTC by Pietro Dania
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-04 02:46:14 UTC


Attachments (Terms of Use)

Description Pietro Dania 2002-11-29 07:21:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux 2.4.18-10; X11; i686; en_US)

Description of problem:
VMware-Workstation 3.2 build 2230 crashes with 'AIO: Not Implemented' when suspending or abrubtely powering off the virtual machine on kernels 2.4.18-17.7.x and 2.4.18-18.7.x BUT NOT with kernel 2.4.18-10

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with either 2.4.18-17.7.x or 2.4.18-18.7.x kernel
2. Run VMware Workstation 3.2 build 2230
3. Boot a Virtual Machine
4. Click on 'suspend'
 

Actual Results:  VMware crashes

Expected Results:  VMware successfully suspends teh virtual machine

Additional info:

Comment 1 Pietro Dania 2002-11-29 07:37:29 UTC
Full text of the VMware error dialog: 
*** 
VMware Workstation Unrecoverable error: (VMX) 
AIO: NOT_IMPLEMENTED F(831):654 
Please request support and include the contents of the log file: 'linux.log'. 
***

Comment 2 Pietro Dania 2003-01-10 12:03:57 UTC
The problem still exists in the latest 2.4.18-19.7.x kernel. 
Where could i get the kernel-2.4.18-10.src.rpm package ? 
Maybe i can fix it for you :-) 

Comment 3 Arjan van de Ven 2003-01-10 12:33:28 UTC
it's a bug in vmware; they need to fix their program.

Comment 4 Petr Vandrovec 2003-01-29 09:09:26 UTC
See http://www.vmware.com/support/kb/enduser/std_adp.php?p_faqid=873 for
solution on this and couple of other VMware related problems (except
ones caused by glibc 2.3.1-nptl.


Note You need to log in before you can comment on or make changes to this bug.