Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78756 - Installation Exception Occured while Installing Packages on Redhat 8.0 gui
Summary: Installation Exception Occured while Installing Packages on Redhat 8.0 gui
Keywords:
Status: CLOSED DUPLICATE of bug 76123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-29 05:00 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:14 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-29 05:00:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
Installing on a Toshiba Satellite Pro 425CDS.  Tried twice with GUI install 
tool.  Exception occurs when Installing Packages page is submitted.  



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Tried RedHat installation 2x.  Blows up same on submition of Installing 
Packages page.
2.
3.
	

Actual Results:  Traceback( most recent call last):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
 self.currentWindow.renderCallback()
File "/usr/lib/anaconda/gui.py", line 149, in renderCallback
 self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", linae 632, in nextClicked
 self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
 self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
 rc = apply(func, self,bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
 partitions.doMetaDeletes(diskset)
File "/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
 searchPath = 1)
File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
 childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Expected Results:  Should build.

Additional info:

Comment 1 Need Real Name 2002-12-02 15:03:57 UTC
This same exception also occurse on this system from the 'linux text' 
installation during the same spot.  The system displayed the depencency widget, 
the formatting file system widget before the error message was productd.

Comment 2 Michael Fulbright 2002-12-02 16:04:04 UTC
How much RAM is in your system?

Comment 3 Need Real Name 2002-12-02 19:08:05 UTC
Currently there is 40M of ram and kernel 2.4.7-10 is running a modified server 
version with Redhat7.2 package versions of all software.


Comment 4 Michael Lee Yohe 2003-01-09 14:01:11 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.

Comment 5 Jeremy Katz 2003-01-10 06:55:25 UTC

*** This bug has been marked as a duplicate of 76123 ***

Comment 6 Greg Hinds 2003-01-30 04:26:17 UTC
What is the resolution?

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.