Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78744 - Command gives gtk-WARNING on server installs
Summary: Command gives gtk-WARNING on server installs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-proc
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-28 15:06 UTC by Mike Chambers
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-29 16:15:41 UTC


Attachments (Terms of Use)

Description Mike Chambers 2002-11-28 15:06:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
On server installs, command gives gtk warning, instead of telling user they 
aren't setup to run this command on their system, due to no GUI running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Perform server install
2.Run redhat-config-proc
3.
	

Actual Results:  Gtk-WARNING **: cannot open display:

Expected Results:  Should just tell user X isn't running, or this command 
can't be used when in this tyep environment or something along those lines.

Additional info:

CC'ing Brent Fox as he is aware and wanted bugs file against each redhat-
config packages until they can't find a solution.

Comment 1 Harald Hoyer 2003-10-24 14:04:26 UTC
this is gtk_init() ... not much I can do about, instead of checking env(DISPLAY)
and argument(-display)... reassigning

Comment 2 Owen Taylor 2003-10-24 14:26:49 UTC
The GTK+ piece is there: gtk_init_check(). You can do with it whatever
you want.


Comment 3 Harald Hoyer 2003-10-24 14:33:25 UTC
ok.. will do later..

Comment 4 Mike Chambers 2004-01-29 13:34:40 UTC
ping...

Just checking the status on this so can possibly close or not.

Comment 5 Harald Hoyer 2004-01-29 16:15:41 UTC
fixed in system-config-proc-0.25


Note You need to log in before you can comment on or make changes to this bug.