Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78720 - gettextize corrupts AM_GNU_GETTEXT_VERSION
Summary: gettextize corrupts AM_GNU_GETTEXT_VERSION
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gettext
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-28 10:45 UTC by Ralf Corsepius
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-28 10:46:56 UTC


Attachments (Terms of Use)
A fix to the problem (deleted)
2002-11-28 10:46 UTC, Ralf Corsepius
no flags Details | Diff

Description Ralf Corsepius 2002-11-28 10:45:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
running gettextize breaks existing AM_GNU_GETTEXT_VERSION in
configure.in|configure.acs

Version-Release number of selected component (if applicable): All versions of
gettext-0.11.x


How reproducible:
Always

Steps to Reproduce:
Write a configure.in|ac containing
AM_GNU_GETTEXT_VERSION(0.11.2)

Then run gettextize -f
	

Actual Results:  gettextize corrupts the line containing AM_GNU_GETTEXT_VERSION
into
AM_GNU_GETTEXT_VERSION(0.11.4

Note the missing closing ')'


Expected Results:  the resulting configure.in|ac should contain
AM_GNU_GETTEXT_VERSION(0.11.4)



Additional info:

This bug seems to be present in all versions of gettext-0.11.x, up to and
including 0.11.5, in RH-Rawhide and RH-8.0

Comment 1 Ralf Corsepius 2002-11-28 10:46:50 UTC
Created attachment 86824 [details]
A fix to the problem

Comment 2 Leon Ho 2002-12-10 05:04:18 UTC
Thanks for your report and patch. gettext-0.11.4-5 has the fix.


Note You need to log in before you can comment on or make changes to this bug.