Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78719 - ANACONDA BUG DURING INSTALLATION
Summary: ANACONDA BUG DURING INSTALLATION
Keywords:
Status: CLOSED DUPLICATE of bug 76123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-28 10:19 UTC by Need Real Name
Modified: 2006-02-21 18:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:14 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-28 10:19:40 UTC
Description of Problem:
installation hangs with execption occured message- "this is probably a 
bug ...file report against anaconda, at bugzilla

Version-Release number of selected component (if applicable):


How Reproducible:
installation

Steps to Reproduce:
1. installation from red hat linux8 - 3 cd set recieved with book redhat linux 8
2. 
3. 

Actual Results:
installation hanga

Expected Results:
installation should have completed

Additional Information:
	Traceback(most recent call last ) :
File "/usr/lib/anaconda/gui.py",line 786, in handleRenderCallback 
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py",line 149, in renderCallback 
self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 631, in nextClicked self.dispatch.gotoNext
()
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 215, in 
rc=apply(func,self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems 
partions.doMetaDeletes(disket)
File "/usr/lib/anaconda/partitions.py", line 1110,in doMetaDeletes lvm.vgativate
()
File "/usr/lib/anaconda/lvm.py", line 54, in vactivate searchPath = 1)
File "/usr/lib/anaconda/iutil.py", line 66,in execWithRedirect childpid=os.fork)
osError:[Errno 12] cannot allocate memory.

Comment 1 jchim32 2002-11-28 21:21:17 UTC
I have the exact problem

Comment 2 Michael Fulbright 2002-12-02 15:54:16 UTC
How much RAM is in your system - 64MB is the minimum requirement.

Comment 3 Need Real Name 2002-12-02 17:48:37 UTC
My system has 64 MB RAM,
and there is 8 GB Free hard disk space for
linux.

Comment 4 Need Real Name 2002-12-03 10:08:59 UTC
I have even tried the text based installation- linux text,
which is supposed to require lesser RAM, and the result
has been same.

Comment 5 Michael Fulbright 2003-01-03 02:47:55 UTC
How much swap do you have allocated?

Comment 6 Michael Lee Yohe 2003-01-09 14:01:41 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.

Comment 7 Need Real Name 2003-01-11 00:42:05 UTC
I have tried with a swap of 128 MB and then with 256 MB.
Also I have tried to install in the text mode as suggested by
Mr Michael Lee Yohe above. Results have been same.


Comment 8 Jeremy Katz 2003-01-11 06:55:30 UTC

*** This bug has been marked as a duplicate of 76123 ***

Comment 9 Greg Hinds 2003-01-30 04:25:42 UTC
How was this resolved?

Comment 10 Michael Lee Yohe 2003-01-30 14:09:07 UTC
It was resolved as a duplicate of 76123.

Alternatively, the new version of Anaconda activates swap at a different time. 
However, the memory requirements of Red Hat Linux 8.0 and 8.1 are still
enforced.  Phoebe (Red Hat Linux 8.1 beta) and the gold edition of 8.1 will have
the requirements specified in the release notes.

Comment 11 Red Hat Bugzilla 2006-02-21 18:50:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.