Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78698 - Xchat crashed when I closed a channel.
Summary: Xchat crashed when I closed a channel.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xchat
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-27 20:17 UTC by Glen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-27 20:17:59 UTC


Attachments (Terms of Use)

Description Glen 2002-11-27 20:17:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Xchat had been running for a few weeks or so connected to one irc server and
about 5 channels on that server.  I opened up about 3 more channels on that
server, connected to another server and opened up about 5 channels on that one.
 I asked some questions on most of the channels.  Then when I went to close one
of the channels, Xchat crashed.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Mike A. Harris 2002-11-27 20:55:11 UTC
A one shot problem causing a crash of an application after several
weeks of usage like this, is not something debuggable.

In order to troubleshoot any type of problem like this, it _has_ to
be reproduceable easily, and in within a timeframe that a developer
can debug it.  Running xchat in gdb for 3 weeks and hoping it crashes
is not very helpful unfortunately.

If you can reproduce this problem again faithfully, and provide
step by step instructions on how to do so within a short order of
time, then please provide the details and reopen the bug report.

Closing WORKSFORME

Comment 2 Glen 2002-11-27 21:36:31 UTC
The same thing actually just happened again.  This time I was only connected to
one server, and exactly 6 channels.  I had asked a few questions on some of the
channels.  I had idled for around 10 minutes or so while I was using my web
browser.  I went back to Xchat and closed one of the tabs and it crashed.  I'm
beginning to wonder if someone is doing this to me.

Comment 3 Glen 2002-12-03 19:26:48 UTC
Once again Xchat crashed when I closed a channel window.  It had been open for
about a week or so.  I can't really reproduce it in a short period of time like
you ask I guess, but it does seem like sooner or later it will happen.


Note You need to log in before you can comment on or make changes to this bug.