Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78697 - unreadable font in dialog
Summary: unreadable font in dialog
Keywords:
Status: CLOSED DUPLICATE of bug 74911
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-27 18:26 UTC by matteo porta
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:13 UTC


Attachments (Terms of Use)

Description matteo porta 2002-11-27 18:26:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
while trying to install the nvidia proprietary xfree drivers the xserver didn't 
start up. i got a error dialog saying:
"i cannot start the x server (your graphical interface). it is likely...etc etc"
this dialog had ok and cancel buttons. well i think they were ok and cancel 
buttons because the text was unreadable... choosing the one on the right closed 
the dialog.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. misconfigure appropiately your xfree server
2. reboot your rh8
3.
	

Additional info:

Comment 1 Michael Lee Yohe 2002-11-27 19:55:37 UTC
Is this due to the video data corruption due to attempted invokation of the
nVidia driver on your system?

Otherwise - you might wish to refer to Bug 78616 - since nVidia _does_ invoke
its own closed, binary-only driver in the kernel and something bad happened to
your system.

Comment 2 matteo porta 2002-11-28 12:12:30 UTC
i dont think the nvidia proprietary driver is the culprit.
i've done this test: renamed the /etc/x11/xf86config file,
so that the xserver can't start. then i've rebooted.
i got the usual dialog with unreadable fonts. then i did
an lsmod, and the nvidia driver wasn't loaded. so it
seems that it's not a problem with nvidia.
i think that the dialog comes from /usr/bin/gdm-binary.


Comment 3 Bill Nottingham 2002-12-02 18:50:10 UTC
We basically need a unicode-capable ncurses

Comment 4 Thomas E. Dickey 2003-01-12 17:53:05 UTC
From the description, I don't see why this one would be related to dialog or ncurses, since it states that the "text" is unreadable.  A font problem would be (going up) the terminal emulator, some issue with the fonts specified, or the X server.

Comment 5 Eido Inoue 2003-01-20 22:03:31 UTC
sounds like the locale is non-English/non-latin-1, and the console is not
Unicode. Need to know what the output of "locale" is.

Comment 6 matteo porta 2003-01-22 18:00:37 UTC
here's what i get when typing locale into a terminal:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Comment 7 Eido Inoue 2003-02-03 22:44:22 UTC

*** This bug has been marked as a duplicate of 74911 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:50:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.