Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7869 - /usr/bin/rftp doesn't run at all
Summary: /usr/bin/rftp doesn't run at all
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
: 6877 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-17 17:58 UTC by twallace
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-18 21:07:16 UTC


Attachments (Terms of Use)

Description twallace 1999-12-17 17:58:21 UTC
/usr/bin/rftp is messed up, and has been for several releases.  Won't even
start up; just try typing rftp.  Line 312 missing quote.  My version works
better with an extra error detection number, as in following diff:

$ diff /usr/bin/rftp myrftp
116c116
<       } -re "(257|550.*exists).*ftp>.*"
---
>       } -re "(257|553|550.*exists).*ftp>.*"
312c312
<       send_user "usage: rftp [host]
---
>       send_user "usage: rftp [host]"

[WHY IS THERE NO EXPECT COMPONENT?!; I LIED ABOUT TCL/TK IN FORM]

Comment 1 Jeff Johnson 1999-12-17 18:15:59 UTC
Thanks for the patch.

Meanwhile, there's no expect component because bugzilla tracks source
rather than binary componenets, and expect is a binary sub-package
generated from the tcltk src.rpm. More than a little confusing to
anybody who isn't intimately familiar with the Red hat distribution,
but that can't be helped currently ...

Comment 2 Bill Nottingham 2000-02-05 20:46:59 UTC
*** Bug 6877 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2000-03-18 21:07:59 UTC
Fixed in tcltk-8.2.3-36. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.