Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78687 - internal error: Floating point exception during srpm rebuild
Summary: internal error: Floating point exception during srpm rebuild
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-27 16:59 UTC by Tim Wunder
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 16:18:28 UTC


Attachments (Terms of Use)

Description Tim Wunder 2002-11-27 16:59:47 UTC
Description of problem:
Trying to rebuild kdelibs-3.0.5 from the SRPM. I executed an 'rpmbuild --rebuild
kdelibs-3.0.5-1.src.rpm' and it progresses for a while, 'til it comes upon this
error:

<quote>
In file included from kdeprint_cups_la.all_cpp.cpp:5:
kmcupsjobmanager.cpp: In member function `void
  KMCupsJobManager::parseListAnswer(IppRequest&, KMPrinter*)':
kmcupsjobmanager.cpp:233: internal error: Floating point exception
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [kdeprint_cups_la.all_cpp.lo] Error 1
make[4]: Leaving directory `/usr/src/redhat/BUILD/kdelibs-3.0.5/kdeprint/cups'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/kdelibs-3.0.5/kdeprint/cups'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/kdelibs-3.0.5/kdeprint'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/kdelibs-3.0.5'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.61797 (%build)
</quote>


Version-Release number of selected component (if applicable):
$ gcc --version
gcc (GCC) 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

How reproducible:
Always

Steps to Reproduce:
1. Download the kdelibs-3.0.5 SRPM from ftp.kde.org for RH8
2. execute rpmbuild --rebuild <rpm>
3. wait for error
	

Actual Results:  rpm rebuild bombs

Expected Results:  rpm rebuild finishes without error

Additional info:
Adding to bugzilla as an error in gcc per e-mail conversation with Than Ngo,
than@redhat.com

Comment 1 Jakub Jelinek 2002-12-04 16:08:36 UTC
If this is reproduceable, please attach preprocessed kdeprint_cups_la.all_cpp.ii
(see g++ -save-temps option) and write the exact g++ arguments that has been
used.

Comment 2 Tim Wunder 2003-01-10 03:59:39 UTC
This was likely a hardware problem. I've eventually determined that my CPU was bad and have 
since replaced my Athlon 950 with a Duron 1GHz and am no longer experiencing this problem 
(not to mention *other* problems that are now gone) 
 


Note You need to log in before you can comment on or make changes to this bug.