Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78621 - up2date crases with traceback on Kernel update
Summary: up2date crases with traceback on Kernel update
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 16:32 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 19:53:43 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-26 16:32:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.up2date -u
2.
3.
	

Actual Results:  [root@screamer48 /root]# up2date -u

Fetching package list for channel: redhat-linux-i386-7.1...
########################################

Fetching package list for channel: redhat-powertools-i386-7.1...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-7.1...
########################################

Fetching Obsoletes list for channel: redhat-powertools-i386-7.1...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.4.18-18.7.x.i686.r ########################## Done.                   
kernel-2.4.18-18.7.x.src.rp ########################## Done.                   
Preparing...                ########################################### [100%]

Installing...
   1:kernel                 ########################################### [100%]
Traceback (innermost last):
  File "/usr/sbin/up2date", line 781, in ?
    main()
  File "/usr/sbin/up2date", line 569, in main
    pkgNames, fullUpdate, dryRun = dry_run))
  File "/usr/sbin/up2date", line 770, in batchRun
    up2date.installBootLoader(batch.kernelsToInstall)
  File "/usr/share/rhn/up2date_client/up2date.py", line 592, in installBootLoader
    __install_lilo(kernelList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 611, in __install_lilo
    ret = lilocfg.installNewImages(kernelList,test=0)
  File "/usr/share/rhn/up2date_client/lilocfg.py", line 274, in installNewImages
    (default, tmptype, default_image,image_path,other,defaultIsOther) = findDefault(config,imagelist)
  File "/usr/share/rhn/up2date_client/lilocfg.py", line 215, in findDefault
    (imagetype, default_image,image_path,other) = config.getImage(default)
  File "/usr/share/rhn/up2date_client/lilo.py", line 140, in getImage
    raise IndexError, "unknown image %s" % (label)
IndexError: unknown image linux
[root@screamer48 /root]# 

Expected Results:  No traceback, no errors.

Additional info:

Could I be setup wrong for updating Kernels, if so, what is proper setup, either with my registration at RHN or my system.

Comment 1 Need Real Name 2002-11-26 16:37:45 UTC
Here is a copy of my lilo.conf file:

[root@screamer48 /etc]# more lilo.conf
boot="/dev/sda"
map=/boot/map
install=/boot/boot.b
prompt
timeout="50"
message=/boot/message
linear
default=linux

image="/boot/vmlinuz-2.4.9-34"
        label="linux"
        initrd="/boot/initrd-2.4.9-34.img"
        read-only
        root="/dev/sda1"

[root@screamer48 /etc]# 


Comment 2 Adrian Likins 2002-12-13 22:33:31 UTC
It seems to be the quotes, up2date isnt expecting lilo's to
have the image name quoted. 

lilo seems to be happy with it quoted or un quoted, though.
I'll see about making sure the next version understands both.

Comment 3 Need Real Name 2003-01-07 20:57:01 UTC
affects us too.

Comment 4 Adrian Likins 2004-08-20 19:53:43 UTC
current versions should handle this (plus grub is now the default)


Note You need to log in before you can comment on or make changes to this bug.