Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78618 - When you go to GNU Programs, Setup, Network Configuration and click Apply it gives error message.
Summary: When you go to GNU Programs, Setup, Network Configuration and click Apply it ...
Keywords:
Status: CLOSED DUPLICATE of bug 59017
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.2
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 16:05 UTC by varuni
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-26 16:33:05 UTC


Attachments (Terms of Use)

Description varuni 2002-11-26 16:05:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When you go to GNU Settings, Network Configuration and click Apply it gives 
error message. See below for the detail error message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.In GNU go to Programs, Setup
2.Then select Network Configuration
3.Make relevent changes and click Apply

	

Actual Results:  I got the following message:


Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981,
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 936,
in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 84bcd90>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [       ]*alias[        ]+eth1[         ]+



Expected Results:  Save and exit without crashing.

Additional info:

Comment 1 Harald Hoyer 2002-11-27 10:49:26 UTC

*** This bug has been marked as a duplicate of 59017 ***


Note You need to log in before you can comment on or make changes to this bug.