Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78611 - idraw files using helvetica font are not displayable using gs
Summary: idraw files using helvetica font are not displayable using gs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: urw-fonts
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 14:21 UTC by Simon Baatz
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-07 13:20:51 UTC


Attachments (Terms of Use)
idraw file that provokes the bug (deleted)
2002-11-26 14:23 UTC, Simon Baatz
no flags Details

Description Simon Baatz 2002-11-26 14:21:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
idraw is a program that uses annotated postscript as its file format. Up to
RedHat Linux 7.2 the files could be displayed correctly. However, since RedHat
7.3 and also in 8.0 ghostscript reports errors when trying to display these files.

The problem disappears if the urw-fonts are replaced by the standard
gnu-ghostscript fonts found at
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/gnu/fonts/gnu-gs-fonts-std-6.0.tar.gz

The same problem was also reported by John Heidemann in:
http://article.gmane.org/gmane.comp.printing.ghostscript.bugs/2432

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a idraw file containing some Text (Helvetica)
2.Start gs <idraw_file>

	

Actual Results:  gs exits with the following error:

GNU Ghostscript 7.05 (2002-04-22)
Copyright (C) 2002 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Loading NimbusRomNo9L-Regu font from
/usr/share/fonts/default/Type1/n021003l.pfb... 2410668 1054046 1642520 347466 0
done.
Loading NimbusSanL-Regu font from /usr/share/fonts/default/Type1/n019003l.pfb...
2785628 1379924 1662616 358654 0 done.
Using NimbusSansL-Regu font for NimbusSanL-Regu.
Error: /rangecheck in --get--
Operand stack:
   --nostringval--   --nostringval--   --nostringval--   descender   0  
--nostringval--   1
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1049/1123(ro)(G)--   --dict:0/20(G)--   --dict:95/200(L)--  
--dict:36/51(L)--   --dict:1/17(L)--   --dict:5/17(L)--   --dict:1/3(L)--  
--dict:13/14(ro)(L)--
Current allocation mode is local
Current file position is 10426
GNU Ghostscript 7.05: Unrecoverable error, exit code 1




Expected Results:  After replacing the n019003l.pfb font, the error goes away:

GNU Ghostscript 7.05 (2002-04-22)
Copyright (C) 2002 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Loading NimbusRomNo9L-Regu font from
/usr/share/fonts/default/Type1/n021003l.pfb... 2410668 1054046 1642520 347466 0
done.
Loading NimbusSanL-Regu font from ./n019003l.pfb... 2728772 1325708 1662616
356198 0 done.
>>showpage, press <return> to continue<<


Additional info: I am not sure whether other font are affected as well,only
Helvetica has been tested.

Comment 1 Simon Baatz 2002-11-26 14:23:25 UTC
Created attachment 86525 [details]
idraw file that provokes the bug

Comment 2 Alex Cherepanov 2005-03-07 11:10:59 UTC
This bug is fixed in the latest version of idraw.
See the discussion in Ghostscript Bugzilla:
http://bugs.ghostscript.com/show_bug.cgi?id=687772

Comment 3 Ngo Than 2005-03-07 13:20:51 UTC
closing it as not a bug in urw-fonts


Note You need to log in before you can comment on or make changes to this bug.