Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78610 - [RFE] up2date graphical mode should support package installation option
Summary: [RFE] up2date graphical mode should support package installation option
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 14:06 UTC by Michael Lee Yohe
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 13:28:41 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-11-26 14:06:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
up2date allows a user to install a package on the console and resolve
dependencies on the fly by specifying a package name after the up2date command.
 RHN online already duplicates the functionality (somewhat) by allowing them to
install packages by selecting them in their profile.

up2date should give the user the ability to select one of two modes of operation:

1. standard "up2date" mode - check system for updates
2. install a new package from RHN

If the user selects the second option, they provide the package name or a part
of the package name.  RHN receives the query and provides a list of the packages
that satisfy/match the query.  The user selects which packages to install to
their system - RHN asks user if they wish to continue install the package (and
any dependencies that the package has).

Many newsgroups which answer questions with regard to missing packages refer to
rpmfind.net - installing non-Red Hat packages deviate from a "Red Hat-only"
system, and could cause compatibility issues that often get raised due to the
users lack of understanding that an RPM is not necessarily a Red Hat RPM.  But,
having the user get their RPMs in one spot (the Red Hat Network) and making it
easy for them should increase adoption of RHN.

The RFE I filed for Bug 78608 would also be a great feature to have.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description

Actual Results:  see description

Expected Results:  see description

Additional info:

Comment 1 Adrian Likins 2003-01-28 06:10:11 UTC
A version of this should be in 3.1.5 depending on some ui discussions
(still not real sure if it should always show this screen, or
only via a commandline options, or whatever...)

Basically at the moment, there is an extra screen that shows you
all the packages available that are not currently installed, and
allows you to pick them to be installed. 

Comment 2 Adrian Likins 2003-01-28 22:43:35 UTC
marking this as modified, for qa to take a look at 

Comment 3 Jay Turner 2003-02-14 13:28:41 UTC
With up2date-3.1.15-7, there's a "--show-package-dialog" option which will allow
for selection from a list of packages which aren't installed on the system.


Note You need to log in before you can comment on or make changes to this bug.