Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78608 - [RFE] up2date should allow users to download packages by specifying a file name
Summary: [RFE] up2date should allow users to download packages by specifying a file name
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 13:57 UTC by Michael Lee Yohe
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-06 22:55:47 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-11-26 13:57:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
rpmfind.net is a powerful query tool for available packages.  One of the nice
features about rpmfind.net is the ability to find a package that contains a
certain file.  up2date should also provide this feature, initially, in the
console mode of the application.

RHN receives the query and provides a list of packages to up2date that can
satisfy the user's request _OR_ tell the user no Red Hat packages contain the
file requested.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. # up2date /usr/bin/jed

Actual Results:  Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...
None of the packages you requested were found, or they are already updated.

Expected Results:  Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...

RHN reports:
/usr/bin/jed is contained in jed-0.99.15-3.i386.rpm
jed-0.99.15-3 has no additional dependencies for your system.

Continue? (Y/n): Y

Testing package set / solving RPM inter-dependencies...
########################################
jed-0.99.15-3.i386.rpm:     ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:jed                    ########################################### [100%]


Additional info:

Comment 1 Mihai Ibanescu 2002-11-26 14:08:57 UTC
Have you tried:

up2date --whatprovides /usr/bin/joe

This will show you the name, version and release of the package providing that
file. You can then up2date that package.

Would this work for you?

Comment 2 Michael Lee Yohe 2002-11-26 14:17:49 UTC
I'm familiar with the --whatprovides option.  However, I think either adding the
ability to say:

# up2date --whatprovides /usr/bin/jed
jed-0.99.15-3
No additional dependencies are necessary to install this package.

Continue with installation (Y/n) :

__ OR __

Something that up2date does not currently allow:
# up2date --whatprovides stty
sh-utils-2.0.12-3
No additional dependencies are necessary to install this package.

Continue with installation (Y/n) :

Currently, it does not report anything (since I did not resolve the path).  Some
users will not understand that some things are placed in /usr/bin, /usr/sbin,
/bin, /sbin.  If, for some reason, a file name is located in two different spots
(and owned by two different packages) - the ambiguity is reported to the user
and tells them the name of the packages that contain that file name.

The aforementioned abilities should be provided in the graphical client since
most users will use the Gnome frontend to up2date.  See Bug 78610.  It would be
easy for the user to determine which package to select, eliminating the
ambiguity, by allowing them to read the package description.

I just thought of another reason this is kind of important.  "Gnome Pilot" is
packaged in "gnome-pilot", but most of the executable files are all named
starting with gpilot or gpilotd.  Having RHN search its database for all
packages containing "gpilotd" within an architecture would simplify package
installation.

Comment 3 Adrian Likins 2003-01-28 00:48:31 UTC
up2date --solvedeps /usr/bin/jed

will find what solves the dep, and all it's deps, and install
it. 

Theres no gui component of this as yet, though I currently
working on something along that line. 


Note You need to log in before you can comment on or make changes to this bug.