Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78596 - strip fails to process arguments after --strip-debug flag
Summary: strip fails to process arguments after --strip-debug flag
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-26 05:02 UTC by Michael Fratoni
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-07 13:34:52 UTC


Attachments (Terms of Use)

Description Michael Fratoni 2002-11-26 05:02:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The following fails to strip the target file:
strip --strip-debug -R .comment $file
While
strip --strip-debug $file && strip -R .comment $file
works as expected.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.execute strip --strip-debug -R .comment $file
2.Check the target file, it is not stripped.
3.
	

Actual Results:  The given file contains no debug symbols, and processing
appears to stop at that point.The -R .comment flag appears to be ignored.
The man page indicates that --strip-debug removes debugging symbols only, but
makes no mention of ignoring any remaining flags.

Expected Results:  The .comment field should have been stripped.

Additional info:

This is entered at the request of a Red Hat developer. While building an rpm
package, I found that the executables were not stripped. The command used in the
specfile is:
strip --strip-debug -R .comment $file
Changing the command to:
--strip-debug $file && strip -R .comment $file
Works as expected.

Comment 1 Jakub Jelinek 2004-10-07 13:34:52 UTC
Can't reproduce this with binutils-2.15.91.0.2-8.
Assume it is fixed.


Note You need to log in before you can comment on or make changes to this bug.