Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78573 - Inserted new graphics card and x-windows looses mouse
Summary: Inserted new graphics card and x-windows looses mouse
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
: 78574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 21:55 UTC by sjarrettsprague
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 19:42:56 UTC


Attachments (Terms of Use)

Description sjarrettsprague 2002-11-25 21:55:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Description of problem:
I have just upgraded my graphics card from a tnt2 card to a geforce4 mx card.
Hardware tool detected the card however on using gnome the mouse has
disappeared. I now have to reinstall redhat linux.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put new graphics card in
2.
3.
	

Actual Results:  Mouse is lost

Expected Results:  I would expect the set-up for an x-windows configuration,
with a opportunity to test eveything should occur after hardware probing. That
is the x-windows configuration that was in the initial install process should be
seen again.

Additional info:

Comment 1 Bill Nottingham 2002-11-25 22:09:40 UTC
*** Bug 78574 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Gregorio 2002-12-07 19:29:53 UTC
To fix this you can run redhat-config-mouse, and select the correct mouse you
need. If you have trouble starting the program without a mouse, remember alt-f2
will bring up a window that lets you run commands. 

Alternately, you can edit your XF86Config manually as root. Find the "mouse"
subsection, and find the "Protocal" subsection and select the correct protocal
for your mouse. In my case the line was:

"Protocal" "PS/2"

and should have been

"Protocal" "ExplorerPS/2"

Because I have a MS Intellimouse explorer. 

You can check the file /usr/X11R6/lib/X11/doc/README.mouse for some information
about mouse protocols and setting up mice.


Comment 3 Bill Nottingham 2005-09-23 19:42:56 UTC
With the change to the input layer for PS/2 and USB mice in the 2.6 kernel, this
should no longer be an issue in releases later than Fedora Core 2. Closing.


Note You need to log in before you can comment on or make changes to this bug.