Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78571 - mounting cd freezes gnome session
Summary: mounting cd freezes gnome session
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 21:49 UTC by sjarrettsprague
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-16 04:52:25 UTC


Attachments (Terms of Use)

Description sjarrettsprague 2002-11-25 21:49:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Description of problem:
I have a ricoh cd-r/rw MP7083A and a LG dvd-rom drd-8160B. I installed redhat
linux 8.0 using the ricoh drive. When I try and play a cd it will mount and play
fine in the dvd-rom drive (hdd) but the system hangs if I insert a cd in the
ricoh drive (hdc). The  gnome session/x session totally freezes, no mouse etc.
The only way to resolve the situation is a hard reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.put cd into ricoh drive
2. system freezes
3.
	

Actual Results:  system freexes

Expected Results:  should mount cd

Additional info:

The ricoh cd-r drive works perfectly in win xp and has worked okay in rh linux
7.0 to 7.3, if dma was diaabled.

Comment 1 sjarrettsprague 2002-11-28 22:29:12 UTC
I believe I have solved the problem. I downloaded hdparm and I looked at the dma
state of dev/hdc. DMA was set as 1  (i.e. on) so I did a hdparm -d0 /dev/hdc.
Following this I was able to insert a cd and it mounted ok.

Comment 2 Havoc Pennington 2002-12-14 02:08:23 UTC
Moving to kernel but I assume they will close it as
a bad hardware issue.

Comment 3 Alan Cox 2002-12-16 04:52:25 UTC
hardware - though it may be related to some kernel timing stuff, so if it still
breaks in the next RH release do open a new bug



Note You need to log in before you can comment on or make changes to this bug.