Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78560 - rebuilding from SRPM attempts to write to /var/log/scrollkeeper.log
Summary: rebuilding from SRPM attempts to write to /var/log/scrollkeeper.log
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ggv
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 21:03 UTC by Michael Lee Yohe
Modified: 2013-04-02 04:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 22:44:53 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-11-25 21:03:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When rebuilding as a normal user, the SRPM build performs:
scrollkeeper-update -p /var/tmp/ggv-1.99.9-root/var/scrollkeeper

Upon doing so - the screen is flooded with the following:
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied
Cannot write to log file: /var/log/scrollkeeper.log : Permission denied

Normal users should have no problems building SRPMs without requiring root
access to access system-level files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the ggv SRPM
2. rpmbuild -ba ggv.spec
3. watch the output from the build
	

Actual Results:  see description

Expected Results:  No modifications should be made to /var/log/scrollkeeper.log

Additional info:

$ rpm -q ggv
ggv-1.99.9-5

Comment 1 George France 2002-12-19 19:32:27 UTC
I am having the same problem on RH-7.2.  I suspect the problem is a missing
file, as when I do:

   rpm -bl ggv.spec

I see:
---------------------------------------------------

Processing files: ggv-1.0.2-5.1
error: Could not open %files file /usr/src/redhat/BUILD/ggv-1.0.2/ggv.lang: No
such file or directory


RPM build errors:
    Could not open %files file /usr/src/redhat/BUILD/ggv-1.0.2/ggv.lang: No such
file or directory

---------------------------------------------------

Best Regards,


--George

Comment 2 Jonathan Blandford 2003-01-15 22:44:53 UTC
Fixed in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.