Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78557 - apxs cannot find instdso.sh
Summary: apxs cannot find instdso.sh
Keywords:
Status: CLOSED DUPLICATE of bug 73428
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 20:01 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-25 20:41:39 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-25 20:01:27 UTC
Description of Problem:
  1) When installing (via apxs -i) a custom authorization module, a script
     called 'instdso.sh' is expected to be executed but does not exist in the
     /usr/lib/httpd/build directory

Version-Release number of selected component (if applicable):
  httpd-2.0.40-8

How Reproducible:
  Create a custom module NOT as part of apache; i.e., as a separate project


Steps to Reproduce:
1. /usr/sbin/apxs -c -lgdbm -ldl mymodule.c
2. /etc/rc.d/init.d/httpd stop
3. /usr/sbin/apxs -i -n auth_gdbm -a mymodule.la
4. /etc/rc.d/init.d/httpd start

Actual Results:
    #/usr/sbin/apxs -i -n auth_gdbm -a mymodule.la
     /usr/lib/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib/httpd/build/libtool'
mod_auth_gdbm.la /usr/lib/httpd/modules
     sh: line 1: /usr/lib/httpd/build/instdso.sh: No such file or directory
     apxs:Error: Command failed with rc=8323072


Expected Results:


Additional Information:

Comment 1 Michael Lee Yohe 2002-11-25 20:41:32 UTC
This is a duplicate of Bug 73428 - you should download the new httpd package
from rawhide, which includes the missing script as of 2.0.40-12 (2.0.40-13 is
latest).

Comment 2 Joe Orton 2002-11-26 14:02:48 UTC

*** This bug has been marked as a duplicate of 73428 ***


Note You need to log in before you can comment on or make changes to this bug.