Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78552 - Invalid argument error when attempting to use des option for encryption (losetup)
Summary: Invalid argument error when attempting to use des option for encryption (lose...
Keywords:
Status: CLOSED DUPLICATE of bug 56698
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 18:29 UTC by Michael Lee Yohe
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-03 20:19:15 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-11-25 18:29:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
# dd if=/dev/zero of=encrypted.img bs=1k count=10000
10000+0 records in
10000+0 records out
# ls -laF
total 10024
drwx------    2 root     root         4096 Nov 25 12:25 ./
drwxr-xr-x    5 root     root         4096 Nov 25 12:25 ../
-rw-r--r--    1 root     root     10240000 Nov 25 12:25 encrypted.img
# losetup -e des /dev/loop0 /opt/secure/encrypted.img 
Password: 
Init (up to 16 hex digits): 
ioctl: LOOP_SET_STATUS: Invalid argument


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a file (for loopback setup)
2. attempt to setup encryption on that file for loopback device
	

Actual Results:  ioctl: LOOP_SET_STATUS: Invalid argument

Expected Results:  losetup should not have had a problem.

Additional info:

Comment 1 Michael Lee Yohe 2002-12-03 20:19:06 UTC
Elliot (and public) - any progress in determining whether it is an isolated
issue?  I've been able to duplicate this on two different Red Hat Linux 8.0 boxes.

Comment 2 Elliot Lee 2002-12-03 22:17:24 UTC
Sorry for the delay. Please read bug #56698 for the (stalled) status of a fix.

*** This bug has been marked as a duplicate of 56698 ***


Note You need to log in before you can comment on or make changes to this bug.