Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78542 - restrict time.nist.gov is bad
Summary: restrict time.nist.gov is bad
Keywords:
Status: CLOSED DUPLICATE of bug 70557
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-date
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 13:42 UTC by Gene Czarcinski
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-25 13:42:55 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2002-11-25 13:42:49 UTC
Description of Problem:
While redhat-config-date-1.5.5-1 is a start, the solution still needs work. 
Unfortuneately, as pointed out in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=70557
restrict needs ip numbers ... not a name.  Unless ntp is changed so restrict
looks up numbers or there is some other magic way to do what restrict
192.43.244.18 would do, this package will need to look up the ip-addr and plug
it into the restrict statement.

After applying 1.5.5-1 and running it to update /etc/ntp.conf, I looked in
/vat/log/messages and found:

ntpd[15033]: getnetnum: "time.nist.gov" invalid host number, line ignored

replacing "time.nist.gov" with "192.43.244.18" and restarting ntpd succeeded.

Comment 1 Gene Czarcinski 2002-11-25 14:42:43 UTC

*** This bug has been marked as a duplicate of 70557 ***


Note You need to log in before you can comment on or make changes to this bug.