Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78538 - libacl.so.1 should be in /lib not /usr/lib
Summary: libacl.so.1 should be in /lib not /usr/lib
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: acl
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 78452 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 10:48 UTC by Olivier Baudron
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-25 10:48:34 UTC


Attachments (Terms of Use)

Description Olivier Baudron 2002-11-25 10:48:28 UTC
libacl-2.0.11-4 installs libacl.so.1 in /usr/lib. This is not compatible with
/bin/rm which should be accessible from a mounted root filesystem only.

# ldd /bin/rm
	libacl.so.1 => /usr/lib/libacl.so.1
	libc.so.6 => /lib/i686/libc.so.6
	libattr.so.1 => /lib/libattr.so.1

I think libacl-2.0.11-2 did the right thing.

Comment 1 Michael K. Johnson 2002-11-26 17:38:33 UTC
>* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
>- Correct patch in previous fix so that shared libraries go in /lib*
>  instead of /usr/lib*

Should be fixed now.

Comment 2 Tim Waugh 2002-11-26 17:58:32 UTC
*** Bug 78452 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.