Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78536 - dvips secure mode incorrectly setup
Summary: dvips secure mode incorrectly setup
Keywords:
Status: CLOSED DUPLICATE of bug 71650
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-25 10:08 UTC by Ian
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-25 10:08:15 UTC


Attachments (Terms of Use)

Description Ian 2002-11-25 10:08:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
The dvips 'secure' mode patch:
Patch85: tetex-1.0.7-dvips-secure.patch
leaves dvips in a 'broken' state.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dvips file.dvi
2.dvips -R0 file.dvi



Actual Results:  This is dvips(k) 5.86 Copyright 1999 Radical Eye Software
(www.radicaleye.com)
' TeX output 2002.11.22:0922' -> |lpr
dvips: ! couldn't open output pipe

Expected Results:  In the second step 2. secure mode should have been switched off.


Additional info:

The secure mode patch isn't complete. The procesing for the -R0
option has not been included

Workaround: put dvips in filter mode:

dvips -f file.dvi | lpr

Comment 1 Tim Waugh 2002-11-25 10:10:23 UTC

*** This bug has been marked as a duplicate of 71650 ***


Note You need to log in before you can comment on or make changes to this bug.