Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78495 - diskcheck fails silently
Summary: diskcheck fails silently
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diskcheck
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 78662 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-24 16:01 UTC by Axel Thimm
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-26 13:22:34 UTC


Attachments (Terms of Use)

Description Axel Thimm 2002-11-24 16:01:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
diskcheck returns without perfoming any action.


Version-Release number of selected component (if applicable):
diskcheck-1.3-2

How reproducible:
Always

Steps to Reproduce:
1.LANG=C LC_ALL=C python -vd /etc/cron.hourly/diskcheck
2.
3.
	

Actual Results:  # /usr/lib/python2.2/encodings/aliases.pyc matches
/usr/lib/python2.2/encodings/aliases.py
import encodings.aliases # precompiled from /usr/lib/python2.2/encodings/aliases.pyc
Python 2.2.1 (#1, Aug 30 2002, 12:15:30) 
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
/etc/cron.hourly/diskcheck: inconsistent use of tabs and spaces in indentation
# /usr/lib/python2.2/string.pyc matches /usr/lib/python2.2/string.py
import string # precompiled from /usr/lib/python2.2/string.pyc
import strop # dynamically loaded from /usr/lib/python2.2/lib-dynload/strop.so


Expected Results:  diskcheck should have reported on file systems which are more
than 90% full.

Additional info:

Comment 1 Harald Hoyer 2002-11-25 10:32:57 UTC
Hopefully fixed with:
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS/diskcheck-1.4-1.src.rpm

Comment 2 Axel Thimm 2002-11-26 13:22:28 UTC
I did rebuilt 1.4-1 on Red Hat 8.0 and the same error persists.

Is the problem perhaps within python 2.2.1 itself, or some module of it?
(I hesitate a bit to upgrade to rawhide's python, as so many redhat tools depend
on python)


Comment 3 Axel Thimm 2002-11-26 13:30:15 UTC
Correction: The warning messages are still there, but diskcheck works
nevertheless. Thanks!

Comment 4 Harald Hoyer 2002-11-27 11:56:35 UTC
*** Bug 78662 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.