Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78493 - Problems with sound in RHL 8.0 and Philips Toucam Pro web camera
Summary: Problems with sound in RHL 8.0 and Philips Toucam Pro web camera
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hotplug
Version: 8.0
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
Depends On:
TreeView+ depends on / blocked
Reported: 2002-11-24 14:24 UTC by Christian Rose
Modified: 2014-03-17 02:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-02-04 20:50:02 UTC

Attachments (Terms of Use)

Description Christian Rose 2002-11-24 14:24:14 UTC
Description of Problem:

I recently bought a Philips Toucam Pro web camera in order to use it with RHL
8.0 and GnomeMeeting. This camera is an USB device and has a built-in
microphone. It worked really well, I just had to plug it in and immediately
after that I had camera pictures in GnomeMeeting! Kickass. With a change in the
"Sound recorder" setting from the value "/dev/dsp" to "/dev/dsp1", my friends
could suddenly also hear me.

However, whenever I reboot, kudzu kicks in and appearantly wants to configure
the sound device in the camera if I still have it plugged in. No matter if I
choose "configure" or "ignore", after that all sound output on the machine is
non-functional -- it seems the default sound output device is then the camera(!)
instead of the sound card, although I'm not able to verify that theory. I have
to unplug the camera and re-plug it again to get sound back in my computer speakers.

Version-Release number of selected component (if applicable):

How Reproducible:

Every time.

Steps to Reproduce:

1. Plug in the Philips Toucam Pro camera in a running system. Note that computer
sound is still functional.
2. Reboot. Note that computer sounds (music, sound events) are now not functional.
3. Unplug the camera and immediately plug it in again. Note that computer sound
now becomes functional.

Actual Results:

Computer sounds (music, sound events) are silent/non-functional.

Expected Results:

Computer sounds (music, sound events) are hearable/playing.

Additional Information:

Comment 1 Kevin Davies 2002-12-22 22:50:43 UTC
May be related to bug 69945, bug 77178, bug 75015. It looks like kudzu us 
having a problem with USB audio devices and breaks the sound configuration on 
reboot. This includes webcams with an inbuilt microphone.

Comment 2 Bill Nottingham 2005-02-04 20:50:02 UTC
Closing out bugs on older, no longer supported, releases. Apologies
for any lack of response. Please reopen if problems persist on more
current releases.

This should be solved with the new hardware initialization in FC3.

Note You need to log in before you can comment on or make changes to this bug.