Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78468 - kernel fails to compile
Summary: kernel fails to compile
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-23 20:16 UTC by Olaf Schnapauff
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-25 09:14:45 UTC


Attachments (Terms of Use)
.config of this kernel compile (deleted)
2002-11-23 20:17 UTC, Olaf Schnapauff
no flags Details

Description Olaf Schnapauff 2002-11-23 20:16:48 UTC
Description of Problem:

cc1: warning: -malign-functions is obsolete, use -falign-functions
ld -m elf_i386 -Ttext 0x100000 -e startup_32 -o bvmlinux head.o misc.o piggy.o
make[2]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/arch/i386/boot/compressed'
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o tools/build
tools/build.c -I/usr/src/linux-2.4.18-18.8.0/include
objcopy -O binary -R .note -R .comment -S compressed/bvmlinux
compressed/bvmlinux.out
tools/build -b bbootsect bsetup compressed/bvmlinux.out CURRENT > bzImage
Root device is (3, 1)
Boot sector 512 bytes.
Setup is 4771 bytes.
System is 769 kB
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/arch/i386/boot'
make -C  kernel CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include
-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686
-malign-functions=4  -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-18.8.0/include/linux/modversions.h" MAKING_MODULES=1 modules
make[1]: Entering directory `/usr/src/linux-2.4.18-18.8.0/kernel'
make[1]: Nothing to be done for `modules'.
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/kernel'
make -C  drivers CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include
-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686
-malign-functions=4  -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-18.8.0/include/linux/modversions.h" MAKING_MODULES=1 modules
make[1]: Entering directory `/usr/src/linux-2.4.18-18.8.0/drivers'
make -C addon modules
make[2]: Entering directory `/usr/src/linux-2.4.18-18.8.0/drivers/addon'
make[2]: Nothing to be done for `modules'.
make[2]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/drivers/addon'
make -C block modules
make[2]: Entering directory `/usr/src/linux-2.4.18-18.8.0/drivers/block'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-18.8.0/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686
-malign-functions=4  -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-18.8.0/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=loop 
-DEXPORT_SYMTAB -c loop.c
cc1: warning: -malign-functions is obsolete, use -falign-functions
In file included from /usr/src/linux-2.4.18-18.8.0/include/linux/prefetch.h:13,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/list.h:6,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/module.h:12,
                 from loop.c:62:
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:51: warning: parameter
names (without types) in function declaration
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:51: field
`loops_per_jiffy_R_ver_str' declared as a function
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:73: invalid suffix on
integer constant
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:73: parse error before
numeric constant
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:73: warning: function
declaration isn't a prototype
In file included from /usr/src/linux-2.4.18-18.8.0/include/linux/prefetch.h:13,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/list.h:6,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/module.h:12,
                 from loop.c:62:
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:258:1: warning: "EISA_bus"
redefined
In file included from /usr/src/linux-2.4.18-18.8.0/include/linux/modversions.h:128,
                 from <command line>:1:
/usr/src/linux-2.4.18-18.8.0/include/linux/modules/i386_ksyms.ver:93:1: warning:
this is the location of the previous definition
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:260: warning: parameter
names (without types) in function declaration
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:436: invalid suffix on
floating constant
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:436: parse error before
numeric constant
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:436:
`kernel_thread_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/asm/processor.h:436: warning: function
declaration isn't a prototype
In file included from loop.c:62:
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:183: invalid suffix on
integer constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:183: parse error before
numeric constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:183:
`inter_module_register_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:183: warning: function
declaration isn't a prototype
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:184: invalid suffix on
integer constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:184: parse error before
numeric constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:184:
`inter_module_unregister_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:184: warning: function
declaration isn't a prototype
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:185:
`inter_module_get_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:185: warning: parameter
names (without types) in function declaration
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:186:
`inter_module_get_request_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:186: warning: parameter
names (without types) in function declaration
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:187: invalid suffix on
integer constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:187: parse error before
numeric constant
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:187:
`inter_module_put_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:187: warning: function
declaration isn't a prototype
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:196:
`try_inc_mod_count_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-18.8.0/include/linux/module.h:196: warning: parameter
names (without types) in function declaration
In file included from /usr/src/linux-2.4.18-18.8.0/include/linux/highmem.h:5,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/pagemap.h:16,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/locks.h:8,
                 from /usr/src/linux-2.4.18-18.8.0/include/linux/blk.h:5,
                 from loop.c:71:
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h: In function `get_pgd_fast':
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:78: `boot_cpu_data_R0657d037'
undeclared (first use in this function)
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:78: (Each undeclared
identifier is reported only once
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:78: for each function it
appears in.)
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h: In function
`free_pgd_fast':/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:89:
`boot_cpu_data_R0657d037' undeclared (first use in this function)
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h: In function
`pte_alloc_one_fast':
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:127:
`boot_cpu_data_R0657d037' undeclared (first use in this function)
/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h: In function
`pte_free_fast':/usr/src/linux-2.4.18-18.8.0/include/asm/pgalloc.h:137:
`boot_cpu_data_R0657d037' undeclared (first use in this function)
In file included from loop.c:79:
/usr/src/linux-2.4.18-18.8.0/include/linux/suspend.h:58:1: warning:
"software_suspend" redefined
In file included from /usr/src/linux-2.4.18-18.8.0/include/linux/modversions.h:264,
                 from <command line>:1:
/usr/src/linux-2.4.18-18.8.0/include/linux/modules/suspend.ver:4:1: warning:
this is the location of the previous definition
loop.c: In function `loop_change_fd':
loop.c:720: warning: implicit declaration of function `kernel_thread_R7e9ebb05'
loop.c:761: warning: label `out_put_all' defined but not used
make[2]: *** [loop.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/drivers/block'
make[1]: *** [_modsubdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/drivers'
make: *** [_mod_drivers] Error 2
[root@runes linux-2.4]#

Version-Release number of selected component (if applicable):
2.4.18-18.8

same problem existed in -17.8

.config attached.



How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Olaf Schnapauff 2002-11-23 20:17:56 UTC
Created attachment 86165 [details]
.config of this kernel compile

Comment 2 Arjan van de Ven 2002-11-25 09:14:38 UTC
looks like you forgot make mrproper

Comment 3 Olaf Schnapauff 2002-11-25 12:34:43 UTC
Sorry, indeed this was overlooked. Closed.


Note You need to log in before you can comment on or make changes to this bug.