Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78466 - lilo.conf loses information when upgrading to new kernel
Summary: lilo.conf loses information when upgrading to new kernel
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-23 18:53 UTC by Barry Brimer
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-11 03:45:41 UTC


Attachments (Terms of Use)

Description Barry Brimer 2002-11-23 18:53:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
When I use lilo as my bootloader in Red Hat 8.0 the `rpm -F kernel-*` process
ends up removing the image section relating to the kernel image that is being
upgraded.  It does not affect the "other" section I have for another OS .. nor
does it remove the information at the top of the file, just the part relating to
the kernel.  When installing the rpm it mentions that grubby has a fatal error
usually 3 times.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use lilo for your boot loader
2.use `rpm -F kernel-*` to upgrade your kernel

	

Actual Results:  I no longer had an image section in my lilo.conf relating to
the kernel I had just installed .. or the previous one!

Expected Results:  One of 2 things:

1.  It shouldn't have touched the lilo.conf
2.  It should have correctly updated my lilo.conf

Additional info:

I am using redhat-supplied everything.  I have done this using the i386 and i686
kernel packages on multiple machines.  My kernel upgrade process now included
copying my lilo.conf to another filename, upgrading my kernel, and replacing the
lilo.conf from my backup file, and adjusting it for the new kernel.

Comment 1 Thomas Cameron 2002-11-23 19:39:48 UTC
I have experienced the same thing on several systems.  I also saw several grubby
errors during the rpm -Fvh process, and errors about there being no template. 
Sorry, did not write the errors down.

Additional info - I chose lilo as my boot loader during setup.

My lilo.conf looked like this before the upgrade:

prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

image=/boot/vmlinuz-2.4.18-14
        label=linux
        initrd=/boot/initrd-2.4.18-14.img
        read-only
        append="root=LABEL=/"


And like this afterwards:

prompt
timeout=50
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear



Comment 2 Jeremy Katz 2003-02-19 07:04:02 UTC
This seems to work for me here with our current code.  Can you provide a
complete list of the errors you receive?  (Additionally, if you could add -x to
the top of /sbin/new-kernel-pkg and then run your freshen with that change and
attach the output, that would be even more helpful).  Also a copy of the
pre-freshen lilo.conf would be useful.

Comment 3 Jeremy Katz 2003-03-20 17:46:55 UTC
Reassigning

Comment 4 Jeremy Katz 2003-06-11 03:45:41 UTC
Closing due to lack of activity.  If you have more information to add, feel free
to reopen this bug report.


Note You need to log in before you can comment on or make changes to this bug.