Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78464 - neat crashes when adding hardware type ethernet
Summary: neat crashes when adding hardware type ethernet
Keywords:
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-23 12:53 UTC by mcgrath
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-23 12:54:06 UTC


Attachments (Terms of Use)

Description mcgrath 2002-11-23 12:53:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.18-18.7.x i686; Nav)

Description of problem:
neat crashes when adding hardware type ethernet.  It has no problem with ISDN,
token ring, or modem, but fails when I try to add type ethernet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. While in neat, click on the tab "Hardware" and then "Add"
2. Select "Ethernet" as the Hardware type and click OK.
	

Actual Results:  error message was displayed and said I should file a bug report
for redhat-config-network

Expected Results:  should have opened a window to allow me to choose a driver
for the new hardware and setup the preferences.

Additional info:

I just updated the kernel to 2.4.18-18.7.x .  I never had this problem in the
previous kernel version.  output of the error message reads as follows:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1049, in on_hardwareAddButton_clicked
    self.showHardwareDialog(type, false)
  File "/usr/sbin/neat", line 1079, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 140, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Comment 1 Harald Hoyer 2002-11-25 10:53:28 UTC

*** This bug has been marked as a duplicate of 76226 ***


Note You need to log in before you can comment on or make changes to this bug.