Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78436 - after installation, can't boot with USB CDROM (empty) plugged in
Summary: after installation, can't boot with USB CDROM (empty) plugged in
Keywords:
Status: CLOSED DUPLICATE of bug 73586
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 20:41 UTC by Pam Huntley
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:12 UTC


Attachments (Terms of Use)

Description Pam Huntley 2002-11-22 20:41:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1

Description of problem:
I can't boot the system after installation if the USB CDROM drive is still
plugged in, but no disk is in the drive, or the drive is not shut.  It works
okay with an empty USB floppy drive attached, or if there is a disk in the USB
CDROM drive.

I only saw this on the ThinkPad X24, not on the ThinkPad T30 that I had
available to test on.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install from USB CDROM
2.  take out CDROM and reboot (leaving CDROM drive plugged in)
3.  get error that selected item cannot fit into memory.


	

Actual Results:  this error appeared on screen after the grub splash screen:
Booting 'Red Hat Linux (2.4.18-14)'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/
 [Linux-bzImage, setup=0x1400, size=0x1154a]

Error 28: Selected item cannot fit into memory

Expected Results:  booting normally.

Additional info:

Again, I only saw this on the X24, not the T30.  But I didn't isntall from USB
CDROM on the T30, as it has an internal one.

So it could be something to do with the memory size on the machines, or it could
be differing levels of USB support, although I don't think that is the case, I
can check.

Comment 1 Jeremy Katz 2002-11-26 22:44:51 UTC
It's mostly a BIOS bug in that there's a lot less low memory available for the
boot loader to use.  CVS grub works around this by making large changes to the
way kernel images are loaded.  This should hopefully be going into rawhide soon.

Comment 2 Jeremy Katz 2002-12-29 06:36:22 UTC
0.93 is released and 0.93-1 should be making its way to rawhide soon

*** This bug has been marked as a duplicate of 73586 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.