Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78431 - i830 DRM: Error in I830WaitLpRing()
Summary: i830 DRM: Error in I830WaitLpRing()
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 19:24 UTC by Matt Domsch
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:12 UTC


Attachments (Terms of Use)
XFree86.0.log (deleted)
2002-11-22 19:25 UTC, Matt Domsch
no flags Details

Description Matt Domsch 2002-11-22 19:24:43 UTC
Description of Problem:
Installed XFree86-4.2.99.2-0.20021110.3 from Rawhide on a RHL8.0 system (Dell 
Latitude C400).  I rebuilt i830.o from XFree86 CVS source 11/20/2002 and 
copied it into place.  Everything works fine if running on the LCD screen.  It 
fails when starting to play a DVD using Ogle when docked and connected to an 
external monitor.  The error is:

Error in I830WaitLpRing(), now is 888619, start is 886618
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: f030 head: f01c len: f001 start 7fef000
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 0 imr: ffff iir: 0
space: 65508 wanted 65528

Fatal server error:
lockup


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

Error in I830WaitLpRing(), now is 890636, start is 888635
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: f070 head: f01c len: f001 start 7fef000
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 0 imr: ffff iir: 0
space: 65444 wanted 65528

FatalError re-entered, aborting
lockup




Version-Release number of selected component (if applicable):
XFree86-4.2.99.2-0.20021110.3

How Reproducible:
Always with external monitor

Steps to Reproduce:
1. Install RHL 8.0.  Upgrade XFree.  Install Ogle and related tools.
2. Play DVD with Ogle on external monitor
3. 

Actual Results:
Bottom 3/4 of screen goes black with white 3-4 single-bit-wide vertical lines 
spaced evenly across the screen. System unresponsive, Magic Sysrq-B reboots.  
Errors above left in XFree86 log.

Expected Results:
DVD would play (as it does on the LCD).

Additional Information:
	
I'll attach the whole XFree86 log.

Comment 1 Matt Domsch 2002-11-22 19:25:48 UTC
Created attachment 86105 [details]
XFree86.0.log

Comment 2 Matt Domsch 2002-11-22 19:27:16 UTC
Running kernel is 2.4.18-18.8.0 plus i830.o DRM from CVS.

Comment 3 Mike A. Harris 2002-11-29 09:53:31 UTC
Can you try using the following option to see what happens:

        Option  "XaaNoSolidFillRect"

Does it change anything?

Comment 4 Matt Domsch 2002-12-02 16:00:31 UTC
Yes, that fixes it, thanks!
Should this be closed, or reported somehow?

Comment 5 Matt Domsch 2002-12-02 16:36:03 UTC
I spoke too soon.
The problem happens at resolution 1280x1024x24bit, with or without
XaaNoSolidFillRect.

The problem does not happen at resolution 1024x768x24bit, with or without
XaaNoSolidFillRect.

(aside, running at 1024x768 with a virtual size of 1280x1024 and starting a
movie in Ogle, then pan the screen to put the movie window into view and the
system rebooted itself.  I hate virtual desktops so I won't worry about it...)

Comment 6 Mike A. Harris 2002-12-15 09:41:50 UTC
Resolving as dupe, please use the dupe to track further progress, and submit
more info if needed.  Thanks.

*** This bug has been marked as a duplicate of 77938 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.