Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7842 - Pb with babel package in LaTeX
Summary: Pb with babel package in LaTeX
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-16 13:32 UTC by Christophe Leroy
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-15 23:18:42 UTC


Attachments (Terms of Use)

Description Christophe Leroy 1999-12-16 13:32:51 UTC
When run latex on next dummy file, it works.


\documentclass{report}
\title{Description du logiciel}
\author{Personne}
\begin{document}
\maketitle
\chapter{Premier chapitre}
Essai
\end{document}


If I add \usepackage[francais]{babel}, it fails like that


This is TeX, Version 3.14159 (Web2C 7.3.1)
(bug.tex
LaTeX2e <1998/12/01> patch level 1
Babel <v3.6x> and hyphenation patterns for american, french, german,
ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/report.cls
Document Class: report 1999/01/07 v1.4a Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
(/usr/share/texmf/tex/generic/babel/babel.def))) (bug.aux)
(/usr/share/texmf/tex/latex/ot2cyr/ot2wncyr.fd)
! Undefined control sequence.
\add@accent ...l \mathchardef \accent@spacefactor
                                                  \spacefactor }\accent #1
#...
l.5 \begin{document}

?

Comment 1 Jeff Johnson 2000-01-15 23:18:59 UTC
I cannot reproduce the problem with the following input:

\documentclass{report}
\usepackage[francais]{babel}
\title{Description du logiciel}
\author{Personne}
\begin{document}
\maketitle
\chapter{Premier chapitre}
Essai
\end{document}

Here's the output I see:
bash$ latex bug
This is TeX, Version 3.14159 (Web2C 7.3.1)
(bug.tex
LaTeX2e <1998/12/01> patch level 1
Babel <v3.6x> and hyphenation patterns for american, french, german, ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/report.cls
Document Class: report 1999/01/07 v1.4a Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/generic/babel/babel.sty
(/usr/share/texmf/tex/generic/babel/frenchb.ldf
(/usr/share/texmf/tex/generic/babel/babel.def))) (bug.aux)
(/usr/share/texmf/tex/latex/ot2cyr/ot2wncyr.fd) [1]
Chapitre 1.
[1] (bug.aux) )
Output written on bug.dvi (2 pages, 616 bytes).
Transcript written on bug.log.

(The above was run on sparc Red Hat 6.1 with tetex-1.0.6-7 installed.)


Note You need to log in before you can comment on or make changes to this bug.