Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7841 - backspace broken without xkb
Summary: backspace broken without xkb
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 7839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-16 13:12 UTC by Marko Macek
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-04 20:55:59 UTC


Attachments (Terms of Use)

Description Marko Macek 1999-12-16 13:12:07 UTC
Backspace key doesn't work correctly if XKB is not used. Not a problem with
the default configuration, but when /var/tmp is full, XKB doesn't work.

I'm not sure if it is possible the disk-full case, but fixing backspace in
non-XKB configuration is a one-liner. (I will post it here).

See also bug# 7839

Comment 1 Marko Macek 1999-12-22 14:52:59 UTC
here is the patch (for one of the later versions of X).

directory: xc/programs/Xserver/hw/xfree86/common

--- xf86KbdLnx.c.orig   Sat Jan  2 16:12:41 1999
+++ xf86KbdLnx.c        Sat Jan  2 16:13:31 1999
@@ -197,7 +197,7 @@
 static KeySym linux_to_x[256] = {
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
-       XK_BackSpace,   XK_Tab,         XK_Linefeed,    NoSymbol,
+       NoSymbol,       XK_Tab,         XK_Linefeed,    NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
@@ -226,7 +226,7 @@
        XK_p,           XK_q,           XK_r,           XK_s,
        XK_t,           XK_u,           XK_v,           XK_w,
        XK_x,           XK_y,           XK_z,           XK_braceleft,
-       XK_bar,         XK_braceright,  XK_asciitilde,  XK_Delete,
+       XK_bar,         XK_braceright,  XK_asciitilde,  XK_BackSpace,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,
        NoSymbol,       NoSymbol,       NoSymbol,       NoSymbol,


Note: I have not tested the patch by recompiling due to disk space
reasons, but binary patching my X server executable produces the desired
effects.

Comment 2 Preston Brown 2000-01-14 16:49:59 UTC
*** Bug 7839 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 2000-02-04 20:55:59 UTC
we fixed this in a slightly different way for 6.2.


Note You need to log in before you can comment on or make changes to this bug.