Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78405 - Installer cannot handle swap on /dev/scsi/sdh0-0c0i0l0p6
Summary: Installer cannot handle swap on /dev/scsi/sdh0-0c0i0l0p6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 13:04 UTC by Ralf Kleineisel
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-22 15:11:31 UTC


Attachments (Terms of Use)

Description Ralf Kleineisel 2002-11-22 13:04:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
While trying to upgrade RH from 7.2 to 8.0 the installer cannot handle my swap
partitions  /dev/scsi/sdh0-0c0i0l0p6 and /dev/scsi/sdh0-0c0i1l0p6

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start install of RH 8.0
2.Choose "Upgrade existing installation"
3.
	

Actual Results:  When the installer searches for an existing linux installation
it looks for swap partitions, too. It cannot handle swap space if the entry in
the fstab is of the form /dev/scsi/sdh0-0c0i0l0p6.
It works after editing the fstab and changing the entry to /dev/sda6.

Expected Results:  Fstab entries of the form /dev/scsi/sdh0-0c0i0l0p6 should be
accepted.

Additional info:

Comment 1 Matt Wilson 2002-11-22 16:11:58 UTC
this looks like you're using scsidev.  We have never used scsidev in Red Hat
Linux.  We can't translate from the /dev/scsi that was created with scsidev to
the actual device that swap is on.  Once sysfs is done we will move to that to
have static mappings for drives.  Till then, this is not supported.


Comment 2 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.