Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78404 - sysctl gives ip_forward a value of 0 right after iptables loads
Summary: sysctl gives ip_forward a value of 0 right after iptables loads
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables
Version: 8.0
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL: http://www.e3.com.au/firewall/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 12:56 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-01 09:52:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-22 12:56:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
sysctl gives ip_forward a value of 0 right after iptables gives it a value of 1.
I did not have this problem with prior versions of redhat.

Nov 22 04:12:07 tower iptables: Loading kernel modules ...
Nov 22 04:12:07 tower iptables: net.ipv4.ip_forward = 1
Nov 22 04:12:07 tower iptables: net.ipv4.ip_dynaddr = 1
Nov 22 04:12:08 tower iptables: net.ipv4.conf.all.rp_filter = 1
Nov 22 04:12:08 tower iptables: Flushing Tables ...
Nov 22 04:12:08 tower iptables: Create and populate custom rule chains ...
Nov 22 04:12:08 tower iptables: Process INPUT chain ...
Nov 22 04:12:08 tower iptables: Process FORWARD chain ...
Nov 22 04:12:08 tower iptables: Process OUTPUT chain ...
Nov 22 04:12:08 tower iptables: Load rules for nat table ...
Nov 22 04:12:08 tower iptables: Load rules for mangle table ...
Nov 22 04:12:08 tower rc: Starting iptables:  succeeded
Nov 22 04:12:08 tower sysctl: net.ipv4.ip_forward = 0
Nov 22 04:12:08 tower sysctl: net.ipv4.conf.default.rp_filter = 1
Nov 22 04:12:08 tower sysctl: kernel.sysrq = 0
Nov 22 04:12:08 toewr sysctl: kernel.core_uses_pid = 1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.During the install of redhat 8.0 I selected no firewall.
2.http://www.e3.com.au/firewall/ is were I got the script
3. install docs are inside the script and run the script
4. reboot 
	

Actual Results:  during boot up, sysctl give ip_forward a value of 0 right after
iptables give it a value of 1.

Expected Results:  ip_forward should have a value of 1 after iptables loads

Additional info:

I solved this issue by adding a line in the rc.local to get the gateway to work
correctly.

echo "1" > /proc/sys/net/ipv4/ip_forward

Im not sure if it is a bug but it sure bugs me! hehe

Comment 1 Michael Schwendt 2002-11-23 20:21:12 UTC
It's not a bug, because you can choose what sysctl will do. Make sure you set 

  net.ipv4.ip_forward = 1

in /etc/sysctl.conf

You can edit it with your favourite editor or with the redhat-config-proc utility.


Note You need to log in before you can comment on or make changes to this bug.